Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Читайте новые сообщения форума форума в RRS-агрегаторах

Автор Тема: DAX Вычисление значения YTD для предыдущего месяца, только если он в том же году  (Прочитано 125 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Добрый вечер,

Вопрос по DAX.

У меня есть measure, которая вычисляет некоторые значения с начала года с использованием TOTALYTD.

Value, YTD:=TOTALYTD([Value];'Calendar' [Date])

Я хотел бы вычислить это значение за предыдущий месяц.

Value, YTD, PrevM:=CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar' [Date]))

Однако, если я сейчас в январе 2017 года, он будет рассчитывать значение декабря 2016 года с начала года.

Как вычислить это значение, только только если предыдущий месяц в том же году?
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +3/-0
  • Онлайн Онлайн
  • Сообщений: 136

Формализованное условие
=ЕСЛИ(ГОД(A1)-ГОД(B1)=0;B1-A1;"")
Записан

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Вот что получилось в итоге:
Value, YTD, PrevM:=IF(YEAR(LASTDATE('Calendar'[Date]))-YEAR(LASTDATE(PREVIOUSMONTH('Calendar'[Date])))=0;CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar'[Date]));BLANK())

Вроде работает.
« Последнее редактирование: 07.02.2017, 23:11:13 от vikttur »
Записан
 



Темы без ответов

13.06.2017 00:27 Сводная таблица: как не вручную отсортировать в опред. порядке (не Custom List) 117
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 387
18.05.2017 15:45 Не работает гиперссылка при копировании. 214
15.03.2017 15:45 автозамена картинок PowerPoint 511
13.03.2017 07:09 Использование базы КЛАДР в exel 749
11.03.2017 13:43 Изменить нумерацию страниц 707
10.03.2017 08:40 Как делать бекапы гугл таблицы? 589
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 789
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1035
12.12.2016 23:39 Расчет заказа по формуле, или использовать формулу Массива 1201





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.164 секунд. Запросов: 28.