Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: DAX Вычисление значения YTD для предыдущего месяца, только если он в том же году  (Прочитано 328 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Добрый вечер,

Вопрос по DAX.

У меня есть measure, которая вычисляет некоторые значения с начала года с использованием TOTALYTD.

Value, YTD:=TOTALYTD([Value];'Calendar' [Date])

Я хотел бы вычислить это значение за предыдущий месяц.

Value, YTD, PrevM:=CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar' [Date]))

Однако, если я сейчас в январе 2017 года, он будет рассчитывать значение декабря 2016 года с начала года.

Как вычислить это значение, только только если предыдущий месяц в том же году?
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

Формализованное условие
=ЕСЛИ(ГОД(A1)-ГОД(B1)=0;B1-A1;"")
Записан

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Вот что получилось в итоге:
Value, YTD, PrevM:=IF(YEAR(LASTDATE('Calendar'[Date]))-YEAR(LASTDATE(PREVIOUSMONTH('Calendar'[Date])))=0;CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar'[Date]));BLANK())

Вроде работает.
« Последнее редактирование: 07.02.2017, 23:11:13 от vikttur »
Записан
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 43
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 499
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 494
23.01.2018 13:46 Найти вероятность повторной покупки 508
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 680
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 802
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1002
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2408
15.03.2017 15:45 автозамена картинок PowerPoint 1505
11.03.2017 13:43 Изменить нумерацию страниц 1731





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.119 секунд. Запросов: 89.