Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: DAX Вычисление значения YTD для предыдущего месяца, только если он в том же году  (Прочитано 225 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Добрый вечер,

Вопрос по DAX.

У меня есть measure, которая вычисляет некоторые значения с начала года с использованием TOTALYTD.

Value, YTD:=TOTALYTD([Value];'Calendar' [Date])

Я хотел бы вычислить это значение за предыдущий месяц.

Value, YTD, PrevM:=CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar' [Date]))

Однако, если я сейчас в январе 2017 года, он будет рассчитывать значение декабря 2016 года с начала года.

Как вычислить это значение, только только если предыдущий месяц в том же году?
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

Формализованное условие
=ЕСЛИ(ГОД(A1)-ГОД(B1)=0;B1-A1;"")
Записан

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Вот что получилось в итоге:
Value, YTD, PrevM:=IF(YEAR(LASTDATE('Calendar'[Date]))-YEAR(LASTDATE(PREVIOUSMONTH('Calendar'[Date])))=0;CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar'[Date]));BLANK())

Вроде работает.
« Последнее редактирование: 07.02.2017, 23:11:13 от vikttur »
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 265
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 391
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1382
15.03.2017 15:45 автозамена картинок PowerPoint 986
11.03.2017 13:43 Изменить нумерацию страниц 1207
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1261
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1427
12.12.2016 23:39 Расчет заказа по формуле, или использовать [abbr=Вводится через Ctrl+Shift+Enter]формулу массива[/abbr] 1492
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 1986
07.08.2016 17:33 Определить нумерацию как элемент стиля 2178





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.085 секунд. Запросов: 89.