Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: DAX Вычисление значения YTD для предыдущего месяца, только если он в том же году  (Прочитано 159 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Добрый вечер,

Вопрос по DAX.

У меня есть measure, которая вычисляет некоторые значения с начала года с использованием TOTALYTD.

Value, YTD:=TOTALYTD([Value];'Calendar' [Date])

Я хотел бы вычислить это значение за предыдущий месяц.

Value, YTD, PrevM:=CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar' [Date]))

Однако, если я сейчас в январе 2017 года, он будет рассчитывать значение декабря 2016 года с начала года.

Как вычислить это значение, только только если предыдущий месяц в том же году?
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Онлайн Онлайн
  • Сообщений: 159

Формализованное условие
=ЕСЛИ(ГОД(A1)-ГОД(B1)=0;B1-A1;"")
Записан

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Вот что получилось в итоге:
Value, YTD, PrevM:=IF(YEAR(LASTDATE('Calendar'[Date]))-YEAR(LASTDATE(PREVIOUSMONTH('Calendar'[Date])))=0;CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar'[Date]));BLANK())

Вроде работает.
« Последнее редактирование: 07.02.2017, 23:11:13 от vikttur »
Записан
 



Темы без ответов

22.08.2017 19:35 Шаг на шкале диаграммы времени 27
19.08.2017 09:41 Задача: разобрать журнал прав доступа из линукса и передать его в MSExcel 52
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 68
17.08.2017 08:29 Расчет работы сотрудника после основного рабочего времени 77
13.06.2017 00:27 Сводная таблица: как не вручную отсортировать в опред. порядке (не Custom List) 368
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 767
18.05.2017 15:45 Не работает гиперссылка при копировании. 417
15.03.2017 15:45 автозамена картинок PowerPoint 660
13.03.2017 07:09 Использование базы КЛАДР в exel 976
11.03.2017 13:43 Изменить нумерацию страниц 871





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.059 секунд. Запросов: 28.