Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: DAX Вычисление значения YTD для предыдущего месяца, только если он в том же году  (Прочитано 451 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Добрый вечер,

Вопрос по DAX.

У меня есть measure, которая вычисляет некоторые значения с начала года с использованием TOTALYTD.

Value, YTD:=TOTALYTD([Value];'Calendar' [Date])

Я хотел бы вычислить это значение за предыдущий месяц.

Value, YTD, PrevM:=CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar' [Date]))

Однако, если я сейчас в январе 2017 года, он будет рассчитывать значение декабря 2016 года с начала года.

Как вычислить это значение, только только если предыдущий месяц в том же году?
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

Формализованное условие
=ЕСЛИ(ГОД(A1)-ГОД(B1)=0;B1-A1;"")
Записан

Timi

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 37

Вот что получилось в итоге:
Value, YTD, PrevM:=IF(YEAR(LASTDATE('Calendar'[Date]))-YEAR(LASTDATE(PREVIOUSMONTH('Calendar'[Date])))=0;CALCULATE([Value, YTD];PREVIOUSMONTH('Calendar'[Date]));BLANK())

Вроде работает.
« Последнее редактирование: 07.02.2017, 23:11:13 от vikttur »
Записан
 



Темы без ответов

07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 96
20.01.2019 12:38 Все варианты частичного суммирования 193
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 152
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 626
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1430
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1432
23.01.2018 13:46 Найти вероятность повторной покупки 1313
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1841
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1600
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 2012





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.097 секунд. Запросов: 98.