Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: Формула с условием, что номера строки и столбца в таблице поиска неизвестны  (Прочитано 83 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Lilya

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Добрый день!
Помогите пожалуйста найти формулу
Для ячейки I2 указать формулу для поиска значения LF S+ для маршрута Волгоград-Петербург на типе транспорта Б-738 в таблице A1:E5, с условием, что номера строки и столбца в таблице поиска неизвестны ( представим, что их 100)
« Последнее редактирование: 30.11.2017, 15:17:15 от Serge 007 »
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +413/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 508
Re: нужно найти формулу
« Ответ #1 : 30.11.2017, 14:59:15 »

Так нужно?
=СУММПРОИЗВ(C2:E5*(I1=C1:E1)*(A2:A5=G2)*(B2:B5=H2))
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Lilya

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5
Re: нужно найти формулу
« Ответ #2 : 30.11.2017, 15:09:02 »

да, спасибо большое!
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +339/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 931
    • Мир Excel
Re: нужно найти формулу
« Ответ #3 : 30.11.2017, 15:15:15 »

Ещё вариант формулой массива:
=ИНДЕКС(C2:E5;ПОИСКПОЗ(G2&H2;A2:A5&B2:B5;);ПОИСКПОЗ(I1;C1:E1;))
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 266
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 391
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1383
15.03.2017 15:45 автозамена картинок PowerPoint 988
11.03.2017 13:43 Изменить нумерацию страниц 1208
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1262
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1429
12.12.2016 23:39 Расчет заказа по формуле, или использовать [abbr=Вводится через Ctrl+Shift+Enter]формулу массива[/abbr] 1494
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 1986
07.08.2016 17:33 Определить нумерацию как элемент стиля 2178





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.08 секунд. Запросов: 91.