Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: как найти сумму трех средних чисел формула  (Прочитано 279 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Юлия Крамская

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

всем привет! помогите пожалуйста в exel создть формулу, которая: из 5 разных чисел отбросит наименьшее и наибольшее и суммирует оставшиеся 3 числа.
Записан

runner

  • Постоялец
  • ***
  • Уважение: +6/-0
  • Оффлайн Оффлайн
  • Сообщений: 131

Формула в A1, числа в следующих пяти ячейках справа
=УРЕЗСРЕДНЕЕ(B1:F1;0,4)*3
Записан

Юлия Крамская

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

спасибо огромное! :) :) :)
Записан

Юлия Крамская

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

Формула в A1, числа в следующих пяти ячейках справа
=УРЕЗСРЕДНЕЕ(B1:F1;0,4)*3


а как сделать чтоб он из 5 чисел отбросил наибольшее и наименьшее и из оставшиеся три числа суммировал и разделил на 3? то есть среднее этих трех чисел нашел.?
Записан

Юлия Крамская

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

Формула в A1, числа в следующих пяти ячейках справа
=УРЕЗСРЕДНЕЕ(B1:F1;0,4)*3

спасибо. сама разобралась
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

дополнительная строка с формулой:
=ЕСЛИ(ИЛИ(НАИМЕНЬШИЙ($B$1:$F$1;1)=B1;НАИБОЛЬШИЙ($B$1:$F$1;1)=B1);0;B1)итоговая формула к последней строке:
=СРЗНАЧ(B3:F3)или:
=(СУММ(B1:F1)-МАКС(B1:F1)-МИН(B1:F1))/3или:
=СУММЕСЛИМН(B1:F1;B1:F1;"<>"&МАКС(B1:F1);B1:F1;"<>"&МИН(B1:F1))/3или:
=СРЗНАЧЕСЛИМН(B1:F1;B1:F1;"<>"&МАКС(B1:F1);B1:F1;"<>"&МИН(B1:F1))
« Последнее редактирование: 19.05.2017, 11:27:47 от zs5 »
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 277
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 402
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1400
15.03.2017 15:45 автозамена картинок PowerPoint 995
11.03.2017 13:43 Изменить нумерацию страниц 1219
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1268
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1437
12.12.2016 23:39 Расчет заказа по формуле, или использовать [abbr=Вводится через Ctrl+Shift+Enter]формулу массива[/abbr] 1504
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 2001
07.08.2016 17:33 Определить нумерацию как элемент стиля 2183





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.123 секунд. Запросов: 94.