Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Перебор ячеек до определённого значения и последующий вывод (не обычная задача)  (Прочитано 350 раз)

0 Пользователей и 1 Гость просматривают эту тему.

shu

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Большая просьба Гуру exel помочь. (файл прикрепляю).
Задача сложная, следующего вида:

в столбце "Наименование" написано название арматуры для строительства, а первая цифра идёт её диаметр.
Например в ячейке В6 арматура/стержень диаметром 8 длиной l=17000.
а в следующих строчках перед длиной идёт уже пустота (она подразумевает что это тоже диаметр 8 просто он не повторяется).

Что необходимо: в столбце D мне нужно вычленить только значения диаметров напротив каждой строчки.

Как это сделать для строчек с полной записью я разобрался (ячейки D2,D4,D6 и т.д.), а как сделать для остальных?

Т.е. нужна какая то формула которая бы смотрела первое значение, например в ячейке В14, и если оно не число а запятая например, то смотрела бы на одну строчку выше, если опять нет числа первого ещё выше -  и так пока не встретит число (в данном случае в ячейке В6); как встретила первое число диаметр, то вывела бы его в ячейку D (D14 в данном случае). Т.е. в итоге с D7:D26 должны быть проставлены цифра 8, с D28:D32 цифра 5 и т.д.).

Надеюсь, что это возможно как то реализовать
Заранее спасибо!

Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +46/-0
  • Оффлайн Оффлайн
  • Сообщений: 912

=ЕСЛИ(ДЛСТР(B2)>10;ЛЕВБ(B2;ПОИСК(" ";B2)-1);D1)
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(--ЛЕВБ(B3)>=0;--ЛЕВБ(B3)<=9);ЛЕВБ(B3;2));D2)
Записан

shu

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Большое спасибо за ответы!!!
Обе формулы работают, ссылаясь на предыдущую ячейку.

НО есть одна не стыковка в обеих:
при удалении одной из строчек, допустим в середине - возникают ошибки в последующих ячейках, т.е. как бы удаляется ячейка на которую ссылается следующая формула что-ли.. надо как то задать может, ссылку на предыдущую ячейку, в виде эта минус 1? :(

Во вложении картинка (удалил строчку между 7 и 8
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +46/-0
  • Оффлайн Оффлайн
  • Сообщений: 912

Вы думаете, можно догадаться о том, что Вы еще делаете с листами?
=ЕСЛИ(ДЛСТР(B2)>10;ЛЕВБ(B2;ПОИСК(" ";B2)-1);ИНДЕКС(D:D;СТРОКА()-1))
Записан

shu

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

при удалении одной из строчек, допустим в середине - возникают ошибки в последующих ячейках, т.е. как бы удаляется ячейка на которую ссылается следующая формула что-ли.. надо как то задать может, ссылку на предыдущую ячейку
Это у же другая тема: Поиск последней заполненной ячейки в столбце Exc
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +46/-0
  • Оффлайн Оффлайн
  • Сообщений: 912

Последняя заполненная здесь ни при чем. Нужно было подправить диапазон в формуле.
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

Супер!
Необходимо искать последнюю заполненную ячейку, иначе результатом удаление формулы в одной из строк, приводит к нулевым результатам в последующих строках
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 96
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 206
13.06.2017 00:27 Сводная таблица: как не вручную отсортировать в опред. порядке (не Custom List) 604
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1050
18.05.2017 15:45 Не работает гиперссылка при копировании. 579
15.03.2017 15:45 автозамена картинок PowerPoint 818
13.03.2017 07:09 Использование базы КЛАДР в exel 1169
11.03.2017 13:43 Изменить нумерацию страниц 1043
10.03.2017 08:40 Как делать бекапы гугл таблицы? 886
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1112





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.085 секунд. Запросов: 41.