Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: Как просуммировать в диапазоне с проверкой условия (апгрейд для СУММЕСЛИ)  (Прочитано 201 раз)

0 Пользователей и 1 Гость просматривают эту тему.

askiy

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Уважаемые специалисты, добрый день!

Будьте добры, подскажите, пожалуйста, как реализовать идею оператора СУММЕСЛИ (SUMIF), но с апгрейдом:

Нужно не просто сложить ячейки диапазона для строк с определенным названием, а нужно еще и проверить, чтобы по соседней ячейке в соседней строке с другим названием исполнялось условие, задаваемое формулой.

Если выразиться через пример, нужно сложить все "доходы" для "месяцев", отстоящих от базового не далее, чем на определенный временной период. "Месяцы" не связаны между собой порядком, это признаки разных организаций, и поэтому они не упорядочены по возрастанию или убыванию. Столбики в таблице тоже добавлять нельзя, можно только формулой.  :)

Файл-табличку в качестве иллюстрации задачки прилагаю. 

Большое спасибо.
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +46/-0
  • Оффлайн Оффлайн
  • Сообщений: 912

=СУММЕСЛИМН(D8:D18;D7:D17;">30000";D7:D17;"<"&D5)Надежнее:
=СУММЕСЛИМН(D8:D18;A7:A17;"МесяцГод";D7:D17;"<"&D5)
Записан

askiy

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Огромное Вам спасибо, уважаемый vikttur, за помощь!
Функция и формула работает! :)
« Последнее редактирование: 19.06.2017, 09:40:21 от vikttur »
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 104
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 222
13.06.2017 00:27 Сводная таблица: как не вручную отсортировать в опред. порядке (не Custom List) 623
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1081
18.05.2017 15:45 Не работает гиперссылка при копировании. 592
15.03.2017 15:45 автозамена картинок PowerPoint 835
13.03.2017 07:09 Использование базы КЛАДР в exel 1183
11.03.2017 13:43 Изменить нумерацию страниц 1059
10.03.2017 08:40 Как делать бекапы гугл таблицы? 900
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1132





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.078 секунд. Запросов: 27.