Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Читайте новые сообщения форума форума в RRS-агрегаторах

Автор Тема: Как просуммировать в диапазоне с проверкой условия (апгрейд для СУММЕСЛИ)  (Прочитано 95 раз)

0 Пользователей и 1 Гость просматривают эту тему.

askiy

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Уважаемые специалисты, добрый день!

Будьте добры, подскажите, пожалуйста, как реализовать идею оператора СУММЕСЛИ (SUMIF), но с апгрейдом:

Нужно не просто сложить ячейки диапазона для строк с определенным названием, а нужно еще и проверить, чтобы по соседней ячейке в соседней строке с другим названием исполнялось условие, задаваемое формулой.

Если выразиться через пример, нужно сложить все "доходы" для "месяцев", отстоящих от базового не далее, чем на определенный временной период. "Месяцы" не связаны между собой порядком, это признаки разных организаций, и поэтому они не упорядочены по возрастанию или убыванию. Столбики в таблице тоже добавлять нельзя, можно только формулой.  :)

Файл-табличку в качестве иллюстрации задачки прилагаю. 

Большое спасибо.
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +44/-0
  • Онлайн Онлайн
  • Сообщений: 878

=СУММЕСЛИМН(D8:D18;D7:D17;">30000";D7:D17;"<"&D5)Надежнее:
=СУММЕСЛИМН(D8:D18;A7:A17;"МесяцГод";D7:D17;"<"&D5)
Записан

askiy

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Огромное Вам спасибо, уважаемый vikttur, за помощь!
Функция и формула работает! :)
« Последнее редактирование: 19.06.2017, 09:40:21 от vikttur »
Записан
 



Темы без ответов

13.06.2017 00:27 Сводная таблица: как не вручную отсортировать в опред. порядке (не Custom List) 116
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 379
18.05.2017 15:45 Не работает гиперссылка при копировании. 214
15.03.2017 15:45 автозамена картинок PowerPoint 509
13.03.2017 07:09 Использование базы КЛАДР в exel 746
11.03.2017 13:43 Изменить нумерацию страниц 704
10.03.2017 08:40 Как делать бекапы гугл таблицы? 587
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 789
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1033
12.12.2016 23:39 Расчет заказа по формуле, или использовать формулу Массива 1198





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.063 секунд. Запросов: 28.