Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: Как просуммировать в диапазоне с проверкой условия (апгрейд для СУММЕСЛИ)  (Прочитано 240 раз)

0 Пользователей и 1 Гость просматривают эту тему.

askiy

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Уважаемые специалисты, добрый день!

Будьте добры, подскажите, пожалуйста, как реализовать идею оператора СУММЕСЛИ (SUMIF), но с апгрейдом:

Нужно не просто сложить ячейки диапазона для строк с определенным названием, а нужно еще и проверить, чтобы по соседней ячейке в соседней строке с другим названием исполнялось условие, задаваемое формулой.

Если выразиться через пример, нужно сложить все "доходы" для "месяцев", отстоящих от базового не далее, чем на определенный временной период. "Месяцы" не связаны между собой порядком, это признаки разных организаций, и поэтому они не упорядочены по возрастанию или убыванию. Столбики в таблице тоже добавлять нельзя, можно только формулой.  :)

Файл-табличку в качестве иллюстрации задачки прилагаю. 

Большое спасибо.
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +46/-0
  • Оффлайн Оффлайн
  • Сообщений: 926

=СУММЕСЛИМН(D8:D18;D7:D17;">30000";D7:D17;"<"&D5)Надежнее:
=СУММЕСЛИМН(D8:D18;A7:A17;"МесяцГод";D7:D17;"<"&D5)
Записан

askiy

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Огромное Вам спасибо, уважаемый vikttur, за помощь!
Функция и формула работает! :)
« Последнее редактирование: 19.06.2017, 09:40:21 от vikttur »
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 277
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 402
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1400
15.03.2017 15:45 автозамена картинок PowerPoint 995
11.03.2017 13:43 Изменить нумерацию страниц 1219
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1268
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1437
12.12.2016 23:39 Расчет заказа по формуле, или использовать [abbr=Вводится через Ctrl+Shift+Enter]формулу массива[/abbr] 1504
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 2001
07.08.2016 17:33 Определить нумерацию как элемент стиля 2183





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.103 секунд. Запросов: 88.