Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Читайте новые сообщения форума форума в RRS-агрегаторах

Автор Тема: Подсчет количества дней за месяц  (Прочитано 647 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Tavlad

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 6

Добрый день!

Мастерами ведется таблица, в которой указывают дату, номер заказа и свою фамилию.
Задача подсчитать какое количество дней отработал каждый мастер за каждый месяц.

Эксперименты не дали никакого результата, помогите, пожалуйста
Записан

Pelena

  • Постоялец
  • ***
  • Уважение: +35/-0
  • Оффлайн Оффлайн
  • Сообщений: 276
Re: Подсчет количества дней за месяц
« Ответ #1 : 19.06.2017, 09:24:31 »

Здравствуйте.
Проще всего сводной. Но можно и формулой
=СУММПРОИЗВ((ТЕКСТ($A$2:$A$16;"ММ.ГГ")=ТЕКСТ(F$9;"ММ.ГГ"))*($C$2:$C$16=$E10))
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +46/-0
  • Оффлайн Оффлайн
  • Сообщений: 924
Re: Подсчет количества дней за месяц
« Ответ #2 : 19.06.2017, 09:44:54 »

=СЧЁТЕСЛИМН($C:$C;$E10;$A:$A;">="&F$9;$A:$A;"<="&КОНМЕСЯЦА(F$9;0))
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #3 : 20.06.2017, 07:37:48 »

дополнительный столбец
=МЕСЯЦ(A2)формула
=СЧЁТЕСЛИМН($D$2:$D$16;МЕСЯЦ(F9);$C$2:$C$16;E10)
Записан

Tavlad

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 6
Re: Подсчет количества дней за месяц
« Ответ #4 : 20.06.2017, 08:42:15 »

Добрый день, Pelena! В вашем примере считает количество заказов за месяц по мастеру, но не количество отработанных дней.
В примерах коллег аналогично считает количество заказов.
Везде выдает, что Иванов отработал в мае 6 дней, но это 6 заказов, а дней там 3
« Последнее редактирование: 20.06.2017, 10:05:58 от vikttur »
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #5 : 20.06.2017, 10:04:42 »

формула
=СЧЁТЕСЛИМН($E$2:$E$16;МЕСЯЦ(G9);$C$2:$C$16;F10;D2:D16;">="&1)
« Последнее редактирование: 21.06.2017, 05:48:19 от zs5 »
Записан

Tavlad

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 6
Re: Подсчет количества дней за месяц
« Ответ #6 : 20.06.2017, 11:08:56 »

zs5, А1 - это заголовок столбца
Не совсем понял вашу реализацию
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #7 : 20.06.2017, 14:08:03 »

добавить еще столбец=A3-A2при А1=1
а формула
=СЧЁТЕСЛИМН($E$2:$E$16;МЕСЯЦ(G9);$C$2:$C$16;F10;D2:D16;">="&1)
« Последнее редактирование: 21.06.2017, 05:47:26 от zs5 »
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #8 : 20.06.2017, 14:13:54 »

zs5, А1 - это заголовок столбца
Не совсем понял вашу реализацию
не А1, а А2=1
второй дополнительный столбец (условие), а в А3 и далее:
=A3-A2
Записан

Tavlad

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 6
Re: Подсчет количества дней за месяц
« Ответ #9 : 20.06.2017, 14:28:20 »

zs5, я не понял вашу идею и запутался где располагаться должны дополнительные столбцы относительно моей таблицы
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #10 : 20.06.2017, 14:36:28 »

zs5,
где располагаться должны дополнительные столбцы относительно таблицы
пример формулы: данные а1:с16; определение месяца в столбце е; проверка на повтор даты d; итоговая формула по усмотрению
Записан

Tavlad

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 6
Re: Подсчет количества дней за месяц
« Ответ #11 : 20.06.2017, 20:12:17 »

zs5, а вы могли бы выложить ваше решение? Не пойму как у меня А2 может ровняться 1, если у меня в столбце А фиксируются даты
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #12 : 21.06.2017, 06:04:05 »

d2=1
« Последнее редактирование: 21.06.2017, 07:36:15 от zs5 »
Записан

Pelena

  • Постоялец
  • ***
  • Уважение: +35/-0
  • Оффлайн Оффлайн
  • Сообщений: 276
Re: Подсчет количества дней за месяц
« Ответ #13 : 21.06.2017, 08:13:06 »

Как вариант, формулой тоже с доп. столбцом (файл2)
Или в Excel 2016 можно построить сводную с помощью PowerPivot с подсчётом уникальных значений (файл3)
Записан

Tavlad

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 6
Re: Подсчет количества дней за месяц
« Ответ #14 : 22.06.2017, 18:59:45 »

zs5, есть одна проблема, когда в один день работают 2 мастера. В итоге день будет засчитываться тому, кто первый зафиксировал заказ в таблице.
Pelena, большое спасибо! Ваше решение работает и всего через 1 дополнительный столбец!  sm_clap
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160
Re: Подсчет количества дней за месяц
« Ответ #15 : 23.06.2017, 18:50:10 »

zs5, В итоге день будет засчитываться тому, кто первый зафиксировал заказ в таблице.
если одинаковое фамилия и имя
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 273
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 396
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1391
15.03.2017 15:45 автозамена картинок PowerPoint 991
11.03.2017 13:43 Изменить нумерацию страниц 1215
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1267
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1432
12.12.2016 23:39 Расчет заказа по формуле, или использовать [abbr=Вводится через Ctrl+Shift+Enter]формулу массива[/abbr] 1499
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 1996
07.08.2016 17:33 Определить нумерацию как элемент стиля 2181





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.117 секунд. Запросов: 128.