Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: Формула с условием, что номера строки и столбца в таблице поиска неизвестны  (Прочитано 292 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Lilya

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Добрый день!
Помогите пожалуйста найти формулу
Для ячейки I2 указать формулу для поиска значения LF S+ для маршрута Волгоград-Петербург на типе транспорта Б-738 в таблице A1:E5, с условием, что номера строки и столбца в таблице поиска неизвестны ( представим, что их 100)
« Последнее редактирование: 30.11.2017, 15:17:15 от Serge 007 »
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 534
Re: нужно найти формулу
« Ответ #1 : 30.11.2017, 14:59:15 »

Так нужно?
=СУММПРОИЗВ(C2:E5*(I1=C1:E1)*(A2:A5=G2)*(B2:B5=H2))
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Lilya

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5
Re: нужно найти формулу
« Ответ #2 : 30.11.2017, 15:09:02 »

да, спасибо большое!
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +340/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 951
    • Мир Excel
Re: нужно найти формулу
« Ответ #3 : 30.11.2017, 15:15:15 »

Ещё вариант формулой массива:
=ИНДЕКС(C2:E5;ПОИСКПОЗ(G2&H2;A2:A5&B2:B5;);ПОИСКПОЗ(I1;C1:E1;))
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

20.01.2019 12:38 Все варианты частичного суммирования 47
18.01.2019 23:35 Собрать отчет по актам выполненных работ 48
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 72
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 546
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1360
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1378
23.01.2018 13:46 Найти вероятность повторной покупки 1257
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1731
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1538
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1931





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.091 секунд. Запросов: 90.