Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: Одной формулой рассчитать сумму продаж по количеству заказанных единиц  (Прочитано 179 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Lilya

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Добрый день!

Помогите пожалуйста с формулой!
Нужно одной формулой рассчитать сумму продаж по количеству заказанных единиц товаров в ячейке B8, используя данные о стоимости товаров в диапазоне D1:E4
Я ранее делала нечто подобное, но с помощью двух формул. Подскажите, как можно рассчитать с помощью одной?

Заранее спасибо!
« Последнее редактирование: 30.11.2017, 15:22:18 от Serge 007 »
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +413/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 508

Так нужно?
=СУММПРОИЗВ(B2:B31*СУММЕСЛИ(D2:D18;A2:A31;E2:E18))
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Lilya

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +339/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 941
    • Мир Excel

Ещё вариант формулой массива:
=СУММ((ТРАНСП(D2:D18)=A2:A31)*(ТРАНСП(E2:E18)*B2:B31))
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 329
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 395
23.01.2018 13:46 Найти вероятность повторной покупки 413
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 553
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 710
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 892
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2237
15.03.2017 15:45 автозамена картинок PowerPoint 1414
11.03.2017 13:43 Изменить нумерацию страниц 1630
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1693





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.085 секунд. Запросов: 90.