Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Автор Тема: Подстановка значений из списка по условию  (Прочитано 442 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Тимур Зайцев

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

Нужно, что бы таблица сама подставляла интерпретацию по условию.
Если значение пустое, значит не проводилось еще исследование, что бы подставляло-"исследование не проводилось", если значение от 0- до7-Соответствует нормальному значению, 8-10- Субклиническая тревога, 11 и выше- Клинически выраженная тревога.
Почитал форумы, написано применить формулу ЕПУСТО , не получается.
Сейчас формула такая.

=ЕСЛИ(B20<7;"Соответствует нормальному значению";ЕСЛИ(И(B20>7;B20<10);"Субклиническая тревога";ЕСЛИ(И(B20>10);"Клинически выраженная тревога"))).
Еще подскажите как лучьше сделать, если есть несколько листов exel , и с первого листа берутся значения во второй лист. На 2 листе идет проверка условия и выдается результат. Сравнивать лучьше с 1 листом или со вторым?
Пример таблицы: https://yadi.sk/d/xDgtm2fo3RuPxE
 
« Последнее редактирование: 01.02.2018, 12:48:00 от Тимур Зайцев »
Записан

runner

  • Постоялец
  • ***
  • Уважение: +7/-0
  • Оффлайн Оффлайн
  • Сообщений: 144
Re: помогите составить формулу
« Ответ #1 : 30.01.2018, 10:50:58 »

значение в A1

=ЕСЛИ(A1="";"Исследование не проводилось";ПРОСМОТР(A1;{0;8;11};{"Соответствует нормальному значению";"Субклиническая тревога";"Клинически выраженная тревога"}))
Записан

Тимур Зайцев

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

Очень большой респект!!!! Я и не знал, что так можно. Очень удобно. Намного удобнее , чем если.))
« Последнее редактирование: 01.02.2018, 12:48:25 от Тимур Зайцев »
Записан

Тимур Зайцев

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4
Re: помогите составить формулу
« Ответ #3 : 30.01.2018, 11:06:04 »

Правда сейчас подставил пустое значение, выдает как результат "0"-"нормальное значение"  (((
Как быть?
Записан

runner

  • Постоялец
  • ***
  • Уважение: +7/-0
  • Оффлайн Оффлайн
  • Сообщений: 144
Re: помогите составить формулу
« Ответ #4 : 30.01.2018, 12:05:35 »

[]
« Последнее редактирование: 30.01.2018, 13:38:21 от runner »
Записан

runner

  • Постоялец
  • ***
  • Уважение: +7/-0
  • Оффлайн Оффлайн
  • Сообщений: 144
Re: помогите составить формулу
« Ответ #5 : 30.01.2018, 12:27:40 »

В Вашем случае ссылку можно сделать =ЕСЛИ(ЕПУСТО(ПАЛАТЫ!E3);"";ПАЛАТЫ!E3)   вместо =ПАЛАТЫ!E3
Записан

Тимур Зайцев

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

Вроде получилось. спасибо.
« Последнее редактирование: 01.02.2018, 12:48:39 от Тимур Зайцев »
Записан
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 569
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 848
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 821
23.01.2018 13:46 Найти вероятность повторной покупки 778
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1057
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1032
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1347
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2952
15.03.2017 15:45 автозамена картинок PowerPoint 1782
11.03.2017 13:43 Изменить нумерацию страниц 2013





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.115 секунд. Запросов: 109.