Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: Подсчет уникальных значений в столбце по условию дат  (Прочитано 379 раз)

0 Пользователей и 1 Гость просматривают эту тему.

AlexSAVV

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Добрый всем день!
Помогите справиться с задачей.
Есть два столбца, один - ID пользователя, другой - даты. И есть строка с датами по неделям (одна дата - начало недели, другая - окончание недели).
Необходимо посчитать количество уникальных ID пользователей в диапазоне дат (за неделю - за первую, вторую и т.д.).
Есть формула которая считает уникальные значения во всем диапазоне
 
=СУММПРОИЗВ(СЧЁТЕСЛИ(A2:A46622;A2:A46622)^(2*ЕПУСТО(A2:A46622)-1))

Но не могу соединить с формулой ЕСЛИ(И(начало недели <= диапазон дат;конец недели> диапазон дат);сюда верхнюю формулу;0)

Кто подскажет?
Спасибо!

П.С. Кстати, эта формула подсчета уникальных значений не справляется с диапазоном в 46621 значением в столбце. 10000 считает, а 20000 уже не хочет (пишет 0).
« Последнее редактирование: 02.03.2018, 10:36:26 от AlexSAVV »
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +340/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 941
    • Мир Excel
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390

AlexSAVV

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Serge 007, файл вложил (не знаю почему первый раз не вложился).
Буду признателен за помощь.
Записан
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 414
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 772
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 724
23.01.2018 13:46 Найти вероятность повторной покупки 704
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 946
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 966
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1264
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2808
15.03.2017 15:45 автозамена картинок PowerPoint 1722
11.03.2017 13:43 Изменить нумерацию страниц 1939





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.136 секунд. Запросов: 101.