Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Читайте новые сообщения форума форума в RRS-агрегаторах

Автор Тема: Суммирование при определенных условиях  (Прочитано 346 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Елена Казимирова

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Всем доброго дня!
Помогите, пожалуйста, доработать формулу подсчета.
Необходимо, чтобы формула работала в оранжевых ячейках аналогично с зелеными (в закладке "РК"), с условием, что диапазон дат для оранжевых ячеек более узкий, чем диапазон в закладке "ЗП".
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 580
  • Доброта спасет мир...

Добрый день, Елена,
Так должно быть?
=СУММПРОИЗВ(--(ЗП!$A$2:ЗП!$A$54>=$C4);--(ЗП!$A$2:$A$54<=$D4);ЗП!$G$2:$G$54)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Елена Казимирова

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Работает!
Большое спасибо, очень выручили!
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 552

Еще вариант
=СУММЕСЛИМН(ЗП!G$2:G$99;ЗП!A$2:A$99;">="&C3;ЗП!A$2:A$99;"<="&D3)На более-менее больших объемах СУММЕСЛИ значительно шустрее СУММПРОИЗВ
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 580
  • Доброта спасет мир...
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 158
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 527
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 369
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 494
20.01.2019 12:38 Все варианты частичного суммирования 645
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 504
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 946
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1735
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1775
23.01.2018 13:46 Найти вероятность повторной покупки 1586





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.097 секунд. Запросов: 106.