Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Автор Тема: Поиск по строке и стобцу, отбор и перемещение в другой лист нужного заначения  (Прочитано 279 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Мален

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

      Доброго времени суток, Форумчане!

   Не могу решить проблему, автоматизировать сбор Факта в модели бюджета Excel. Мне необходима формула по которой в ячейку I9 листа ФОТ попало значение из листа ЗУП столбца "Всего включено в ведомости за январь" строки AF2 (Нужно, чтоб поиск и отбор этого столбца был именно по названию, так как по аналогии будет "Всего включено в ведомости за февраль" и т.п.) и ФИО сотрудника из столбца Сотрудник. Т.е. в эту ячейку листа ФОТ должна попасть цифра начисленной з/п из листа ЗУП стоящая в столбце  "Всего включено в ведомости за январь" у Иванова И.И. Уже сутки не могу разобраться :'(
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 520

Так нужно?
=ВПР($C9;ЗУП!$A$4:$BZ$25;ПОИСКПОЗ("Всего включено в ведомости за "&ТЕКСТ(G$6;"ММММ");ЗУП!$B$2:$BZ$2;);)
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Мален

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

   Практически ;), только он из другого столбца цифру взял, надо было чтоб туда попало 50 025.
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +28/-0
  • Оффлайн Оффлайн
  • Сообщений: 501
  • Доброта спасет мир...

еще вариант, с функцией ИНДЕКС. преимущество в том, что нет жесткой привязки к размеру диапазона.
=INDEX(INDIRECT("ЗУП!C"&MATCH("Всего включено в ведомости за "&TEXT(R6C[-2];"[$-ru-RU]mmmm");ЗУП!R2;0);0);MATCH(RC3;ЗУП!C1;0))обращаю внимание, что в функции TEXT(R6C[-2];"[$-ru-RU]mmmm")
[$-ru-RU] - надо указать если региональные настройки не русские
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 520

только он из другого столбца цифру взял
Ну да, правильно. Вот так нужно
=ВПР($C9;ЗУП!$A$4:$BZ$25;ПОИСКПОЗ("Всего включено в ведомости за "&ТЕКСТ(G$6;"ММММ");ЗУП!$A$2:$BZ$2;);)
преимущество в том, что нет жесткой привязки к размеру диапазона
А минус в том, что используется волатильная ДВССЫЛ, которая при более-менее большом количестве таких формул будет подвисать
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Мален

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

  Спасибочки ВСЕМ большое!!!! Работает ;D
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +28/-0
  • Оффлайн Оффлайн
  • Сообщений: 501
  • Доброта спасет мир...

у меня уже много лет Excel постоянно в мануале, поэтому упустил этот момент
используется волатильная ДВССЫЛ
ну если избавляться от "летучести", то тогда так
=INDEX(ЗУП!R1:R1048576;MATCH(RC3;ЗУП!C1;0);MATCH("Всего включено в ведомости за "&TEXT(R6C[-2];"[$-ru-RU]mmmm");ЗУП!R2;0))Диапазон все равно задавать :(
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Ольга Лашина

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 1

Добрый день. Не могу найти в интернете подсказку. Есть очень сложная таблица, мне необходимо сделать из нее простую. Таблица представляет собой прайс, в первом столбце идет перечень наименований товара через запятую, имеются несколько информационных строк и пересечение этих строк и столбцов есть стоимость товара. Как сделать прайс нормальный по каждой позииции? всю голову сломала, все видео посмотрела, но никак не получается. В первом файле - та таблица, которую надо преобразовать. во втором файле - пример, как должна выглядеть таблица. Очень прошу - помогите с формулой.
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +47/-0
  • Оффлайн Оффлайн
  • Сообщений: 965

Вопрос не по теме.
Будете создавать отдельную тему, дайте ей название, отражающее суть задачи, приекрепите небольшой пример в Excel
Записан
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 403
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 763
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 714
23.01.2018 13:46 Найти вероятность повторной покупки 695
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 934
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 953
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1250
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2790
15.03.2017 15:45 автозамена картинок PowerPoint 1713
11.03.2017 13:43 Изменить нумерацию страниц 1928





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.095 секунд. Запросов: 100.