Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Поиск по строке и стобцу, отбор и перемещение в другой лист нужного заначения  (Прочитано 109 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Мален

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

      Доброго времени суток, Форумчане!

   Не могу решить проблему, автоматизировать сбор Факта в модели бюджета Excel. Мне необходима формула по которой в ячейку I9 листа ФОТ попало значение из листа ЗУП столбца "Всего включено в ведомости за январь" строки AF2 (Нужно, чтоб поиск и отбор этого столбца был именно по названию, так как по аналогии будет "Всего включено в ведомости за февраль" и т.п.) и ФИО сотрудника из столбца Сотрудник. Т.е. в эту ячейку листа ФОТ должна попасть цифра начисленной з/п из листа ЗУП стоящая в столбце  "Всего включено в ведомости за январь" у Иванова И.И. Уже сутки не могу разобраться :'(
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +414/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 513

Так нужно?
=ВПР($C9;ЗУП!$A$4:$BZ$25;ПОИСКПОЗ("Всего включено в ведомости за "&ТЕКСТ(G$6;"ММММ");ЗУП!$B$2:$BZ$2;);)
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Мален

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

   Практически ;), только он из другого столбца цифру взял, надо было чтоб туда попало 50 025.
Записан

boa

  • Глобальный модератор
  • Постоялец
  • *****
  • Уважение: +26/-0
  • Оффлайн Оффлайн
  • Сообщений: 471
  • Доброта спасет мир...

еще вариант, с функцией ИНДЕКС. преимущество в том, что нет жесткой привязки к размеру диапазона.
=INDEX(INDIRECT("ЗУП!C"&MATCH("Всего включено в ведомости за "&TEXT(R6C[-2];"[$-ru-RU]mmmm");ЗУП!R2;0);0);MATCH(RC3;ЗУП!C1;0))обращаю внимание, что в функции TEXT(R6C[-2];"[$-ru-RU]mmmm")
[$-ru-RU] - надо указать если региональные настройки не русские
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +414/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 513

только он из другого столбца цифру взял
Ну да, правильно. Вот так нужно
=ВПР($C9;ЗУП!$A$4:$BZ$25;ПОИСКПОЗ("Всего включено в ведомости за "&ТЕКСТ(G$6;"ММММ");ЗУП!$A$2:$BZ$2;);)
преимущество в том, что нет жесткой привязки к размеру диапазона
А минус в том, что используется волатильная ДВССЫЛ, которая при более-менее большом количестве таких формул будет подвисать
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Мален

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

  Спасибочки ВСЕМ большое!!!! Работает ;D
Записан

boa

  • Глобальный модератор
  • Постоялец
  • *****
  • Уважение: +26/-0
  • Оффлайн Оффлайн
  • Сообщений: 471
  • Доброта спасет мир...

у меня уже много лет Excel постоянно в мануале, поэтому упустил этот момент
используется волатильная ДВССЫЛ
ну если избавляться от "летучести", то тогда так
=INDEX(ЗУП!R1:R1048576;MATCH(RC3;ЗУП!C1;0);MATCH("Всего включено в ведомости за "&TEXT(R6C[-2];"[$-ru-RU]mmmm");ЗУП!R2;0))Диапазон все равно задавать :(
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

19.06.2018 16:25 Ввод данных с определенными условиями 10
22.05.2018 11:38 Скрипт написать который допишет данные в файл 153
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 590
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 558
23.01.2018 13:46 Найти вероятность повторной покупки 569
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 757
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 839
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1068
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2502
15.03.2017 15:45 автозамена картинок PowerPoint 1559





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.094 секунд. Запросов: 96.