Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Выполнение умножения при определенном условии  (Прочитано 176 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Петр Абрамов

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Всем привет! Ребята, помогите, пожалуйста!!! Есть длинные столбцы с ценами и долями. Нужно перемножить цену и долю в общем объеме, исходя из артикля. Проблема в том, что объемы указаны еще и по многим др. артиклям, которые мне не нужны. И простое перемножение с помощью "растягивания" столбца приведет к ошибкам. Я понимаю, что нужно сделать такое условие: перемножать в том случае, если артикль по цене = артикль по доле, если такого нет вообще во всем столбце, то 0. Но какую формулу использовать не знаю! Формула "ЕСЛИ с множеством условий - тоже не вариант.
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 527

Кросс с ответом http://www.excelworld.ru/forum/2-38710-1#256178


О кроссах сообщать нужно
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 540
  • Доброта спасет мир...

Добрый день,
Наверное так?

=СУММПРОИЗВ(--($D$2:$D$2736=$G2);$E$2:$E$2736)*$I2
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Петр Абрамов

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Добрый день,
Наверное так?

=СУММПРОИЗВ(--($D$2:$D$2736=$G2);$E$2:$E$2736)*$I2

Проверил простым умножением, неверно...
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 540
  • Доброта спасет мир...

Проверил простым умножением, неверно...
Для читабельности я между таблицами вставлял пустые колонки, поэтому для вашего файла формула выглядит так:
=СУММПРОИЗВ(--($C$2:$C$2736=$E2);$D$2:$D$2736)*$G2

а лучше откройте файл приложенный к предыдущему посту и посмотрите в нем.
отличие(но не ошибка) может быть лишь в одном случае, если коды в каждой отдельно взятой таблице не уникальны, тогда результат будет просто дублироваться. для каждого дубля кода в таблице с долями.
Но дублей в таблицах нет. Ошибки быть не может!
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 390
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1183
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1183
23.01.2018 13:46 Найти вероятность повторной покупки 1077
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1512
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1365
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1715
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 3470
15.03.2017 15:45 автозамена картинок PowerPoint 1968
11.03.2017 13:43 Изменить нумерацию страниц 2097





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.106 секунд. Запросов: 105.