Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Автор Тема: Суммирование при определенных условиях  (Прочитано 114 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Елена Казимирова

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Всем доброго дня!
Помогите, пожалуйста, доработать формулу подсчета.
Необходимо, чтобы формула работала в оранжевых ячейках аналогично с зелеными (в закладке "РК"), с условием, что диапазон дат для оранжевых ячеек более узкий, чем диапазон в закладке "ЗП".
Записан

boa

  • Глобальный модератор
  • Постоялец
  • *****
  • Уважение: +27/-0
  • Оффлайн Оффлайн
  • Сообщений: 487
  • Доброта спасет мир...

Добрый день, Елена,
Так должно быть?
=СУММПРОИЗВ(--(ЗП!$A$2:ЗП!$A$54>=$C4);--(ЗП!$A$2:$A$54<=$D4);ЗП!$G$2:$G$54)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Елена Казимирова

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Работает!
Большое спасибо, очень выручили!
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 519

Еще вариант
=СУММЕСЛИМН(ЗП!G$2:G$99;ЗП!A$2:A$99;">="&C3;ЗП!A$2:A$99;"<="&D3)На более-менее больших объемах СУММЕСЛИ значительно шустрее СУММПРОИЗВ
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

boa

  • Глобальный модератор
  • Постоялец
  • *****
  • Уважение: +27/-0
  • Оффлайн Оффлайн
  • Сообщений: 487
  • Доброта спасет мир...
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 286
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 667
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 633
23.01.2018 13:46 Найти вероятность повторной покупки 634
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 847
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 898
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1139
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2627
15.03.2017 15:45 автозамена картинок PowerPoint 1629
11.03.2017 13:43 Изменить нумерацию страниц 1857





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.287 секунд. Запросов: 105.