Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: Сравнить значения таблиц последовательно и вывести разницу  (Прочитано 119 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Ирина18

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Здравствуйте.
Есть файл "Счет" и несколько файлов "Заказ", в файлах заказ присутствуют все позиции товаров и кол-во из "Счет", в "Счет" могут отсутствовать некоторые, которые есть в "Заказ". в фалах "Заказ" позиции могут повторяться между собой, в "Счет" их общее количество.
Можно ли сделать сравнение поочередно, например, "Счета" и "Заказ" с наглядным выведением (цветовая заливка, например или жирное выделение и т. п.) отсутствующих позиций, а также разницы в кол-ве. При этом, если в "Счет" есть, например, "Тетрадь №1" 10шт, они есть в "Заказ 1" 4шт, "Заказ2" 5шт и "Заказ3" 6шт, при сверке "Заказ3", учитывал, что там уже -5

Есть ли путь решения?

P.s. Наименование товаров могут полностью совпадать, либо в них может быть где-то отличие, например лишняя точка, пробел и т. п.  - если есть отличия это сильно осложнит работу?
Примеры прикрепляю
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +31/-0
  • Оффлайн Оффлайн
  • Сообщений: 519
  • Доброта спасет мир...

Можно сделать в файле СЧЕТ доп.столбец в который при помощи функции ВПР подтянуть данные из файла ЗАКАЗ
например:
=ЕСЛИОШИБКА(ВПР(RC3;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!R2C1:R9C2;2;0);"")ну а потом, на основании этого столбца, сделать условное форматрирование
Цитировать
(цветовая заливка, например или жирное выделение и т. п.)
Но название товара должно полностью сопадать, в противном случае задача сильно усложняется.
Ну или поищите в интернете функцию поиска по неточному совпадению FuzzyVLOOKUP

Этих столбцов может быть несколько(по количесту ЗАКАЗов) и итоговый столбец с суммой.
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Ирина18

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Спасибо за информацию и идею. Про ВПР и не подумала даже...
Можно сделать в файле СЧЕТ доп.столбец в который при помощи функции ВПР подтянуть данные из файла ЗАКАЗ
например:
=ЕСЛИОШИБКА(ВПР(RC3;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!R2C1:R9C2;2;0);"")


Попробовала, правда, код пришлось подредактировать, у меня сработало вот так.
=ЕСЛИОШИБКА(ВПР(C7;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!$A$2:$B$9;2;0);"")Как и форматирование работает только при полном совпадении имен, но ручной работы в разы меньше. Попробую с несколькими листами и столбцами еще.
Пошла читать подробно про FuzzyVLOOKUP, с первого взгляда интересно, но как ее сюда "привязать"
Спасибо еще раз.
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +31/-0
  • Оффлайн Оффлайн
  • Сообщений: 519
  • Доброта спасет мир...

для ячейки AI111
=ЕСЛИОШИБКА(ВПР(FuzzyVLOOKUP($C111;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!$A$2:$A$9;0);'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!$A$2:$B$9;2;0);"")
Попробовала, правда, код пришлось подредактировать, у меня сработало вот так.
у меня привычный стиль ссылок R1C1
« Последнее редактирование: 28.07.2018, 17:20:07 от boa »
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 570
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 848
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 821
23.01.2018 13:46 Найти вероятность повторной покупки 778
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1060
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1033
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1347
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2953
15.03.2017 15:45 автозамена картинок PowerPoint 1782
11.03.2017 13:43 Изменить нумерацию страниц 2013





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.107 секунд. Запросов: 103.