Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Автор Тема: Нужна формула по суммированию чисел  (Прочитано 181 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Сергей Великоростов

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Добрый день помогите пожалуйста с формулой суммирования чисел в Excel

У меня таблица разбита на 31 день
в ячейках прописаны цифры срабатывания технических средств охраны
Пример:
 | 1 день| 2 день| 3 день | 4 день | 5 день |.........|  Всего |
 |______|______|______|_______|______|_____ |______|
 |  10/1  |  10/4  |    5/1   |    8      |   7/1   |..........|  40/7  |   
первое число: сколько всего за день срабатываний, а второе (через слэш) сколько из них ложных срабатываний
Нужна формула для сложения этих чисел: = 1 день+ 2 день + 3 день...... ВСЕГО: 40/7
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +48/-0
  • Оффлайн Оффлайн
  • Сообщений: 978

Сумма левых частей:
=СУММ(--ЛЕВБ(A2:G2;ПОИСК("/";A2:G2)-1))Сумма правіх частей:
=СУММ(--ПСТР(A2:G2;ПОИСК("/";A2:G2)+1;5))=суммЛ&"/"&суммПи ввести формулу как формулу массива - тремя клавишами Ctrl+Shift+Enter
« Последнее редактирование: 23.08.2018, 12:19:15 от vikttur »
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 525

У меня такой немассивный вариант (работает с 8 и с пусто)
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ(A2:AE2&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(A2:AE2&"/";"/";"        0");8;9))
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Сергей Великоростов

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Спасибо) еще есть вопрос) нужно еще, что бы формула работала и по вертикали,просчитывала ИТОГ (Ячейки с B58-AF58) по дням. (таблица в приложении)

Если можно еще заблокировать данные ячейки (выделенные красным цветом) что бы формулу в последствии не смогли удалить.
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +31/-0
  • Оффлайн Оффлайн
  • Сообщений: 519
  • Доброта спасет мир...

Здравствуйте, Сергей,
если использовать формулу Александра(_Boroda_), до для вертикальных подсчетов она будет выглядеть так:
=SUMPRODUCT(--LEFTB(SUBSTITUTE(B$3:B$57&"/";"/";"        0");9))&"/"&SUMPRODUCT(--MID(SUBSTITUTE(B$3:B$57&"/";"/";"        0");8;9))
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");8;9))
А как заблокировать ячейки на листе, лучше расскажет Майкрософт.
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Сергей Великоростов

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Цитировать
=SUMPRODUCT(--LEFTB(SUBSTITUTE(B$3:B$57&"/";"/";"        0");9))&"/"&SUMPRODUCT(--MID(SUBSTITUTE(B$3:B$57&"/";"/";"        0");8;9))
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");8;9))


пробую вставить данную формулу, выпадает окно "ошибка в формулы"

можно попросить формулу прописать в моей таблице. (таблица во вложении). За ранее спасибо.

Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +31/-0
  • Оффлайн Оффлайн
  • Сообщений: 519
  • Доброта спасет мир...

Цитировать
=SUMPRODUCT(--LEFTB(SUBSTITUTE(B$3:B$57&"/";"/";"        0");9))&"/"&SUMPRODUCT(--MID(SUBSTITUTE(B$3:B$57&"/";"/";"        0");8;9))
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");8;9))

Это две одинаковые формулы для русского и англицкого интерфейсов
вам, наверное, нужна вторая...

забирайте из вложения
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 571
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 848
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 821
23.01.2018 13:46 Найти вероятность повторной покупки 778
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1060
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1033
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1347
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2953
15.03.2017 15:45 автозамена картинок PowerPoint 1782
11.03.2017 13:43 Изменить нумерацию страниц 2013





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.177 секунд. Запросов: 109.