Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Автор Тема: Перемножение столбцов по условию  (Прочитано 214 раз)

0 Пользователей и 1 Гость просматривают эту тему.

sdqwe

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Добрый день!

Можно ли сократить данную формулу?

=СУММ(ЕСЛИ(C7=1;ПРОИЗВ(C7:D7);0);ЕСЛИ(C8=1;ПРОИЗВ(C8:D8);0);ЕСЛИ(C9=1;ПРОИЗВ(C9:D9);0);ЕСЛИ(C10=1;ПРОИЗВ(C10:D10);0);ЕСЛИ(C11=1;ПРОИЗВ(C11:D11);0);ЕСЛИ(C12=1;ПРОИЗВ(C12:D12);0);ЕСЛИ(C13=1;ПРОИЗВ(C13:D13);0);ЕСЛИ(C14=1;ПРОИЗВ(C14:D14);0);ЕСЛИ(C15=1;ПРОИЗВ(C15:D15);0);ЕСЛИ(C16=1;ПРОИЗВ(C16:D16);0);ЕСЛИ(C17=1;ПРОИЗВ(C17:D17);0);ЕСЛИ(C18=1;ПРОИЗВ(C18:D18);0);ЕСЛИ(C19=1;ПРОИЗВ(C19:D19);0);ЕСЛИ(C20=1;ПРОИЗВ(C20:D20);0);ЕСЛИ(C21=1;ПРОИЗВ(C21:D21);0);ЕСЛИ(C22=1;ПРОИЗВ(C22:D22);0);ЕСЛИ(C23=1;ПРОИЗВ(C23:D23);0);ЕСЛИ(C24=1;ПРОИЗВ(C24:D24);0);ЕСЛИ(C25=1;ПРОИЗВ(C25:D25);0))
Спасибо!
« Последнее редактирование: 08.09.2018, 00:14:35 от vikttur »
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 540
  • Доброта спасет мир...
Re: Упростить формулу
« Ответ #1 : 29.08.2018, 21:06:29 »

а файл?
правила читали?
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 990
Re: Упростить формулу
« Ответ #2 : 29.08.2018, 22:11:31 »

Файла нет, название темы ни о чем, ник - издевательство над читающими.
Записан

sdqwe

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3
Re: Упростить формулу
« Ответ #3 : 30.08.2018, 05:07:33 »

Если внимательно посмотреть на формулу, то станет ясно, что она состоит из повторов:

=СУММ(
ЕСЛИ(C7=1;ПРОИЗВ(C7:D7);0);
ЕСЛИ(C8=1;ПРОИЗВ(C8:D8);0);
...
)

И станет ясно, что используется всего 2 столбца. Простейшая таблица. Файл я не могу предоставить, так как нет у меня к нему доступа в данный момент.

Возможно ли упростить формулу? Может есть возможность сделать произведение построчно в диапазоне, а после суммировать результаты и сумму положить в определённую ячейку более простым способом. В моём варианте придётся при добавлении новых строк вносить новые элементы в формулу.

Примерная таблица:

Тара, л Количество
1 1
1 2
3 1
1 3
2 3

Надо подсчитать количество тары 1 л.

зы.
Файла нет, да.
Название темы отражает суть вопроса.
Ник ничем не отличается от Вашего, так как является производным от моего реального ФИО.

Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 540
  • Доброта спасет мир...
Re: Упростить формулу
« Ответ #4 : 30.08.2018, 09:00:45 »

ну что ж, не хотите сделать файл примера, не надо.
формулу упростить можно, только у меня Excel англицкий и стиль ссылок R1C1
=SUMPRODUCT(--(R7C3:R25C3=1);R7C3:R25C3;R7C4:R25C4)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

sdqwe

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3
Re: Упростить формулу
« Ответ #5 : 30.08.2018, 09:56:07 »

Большое спасибо!
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 540
  • Доброта спасет мир...
Re: Упростить формулу
« Ответ #6 : 31.08.2018, 21:42:15 »

Специально перевел Excel в русский интерфейс, что бы вашу формулу перекопировать и сделать файл-пример и оказалось, что в вашей формуле явная ошибка, может даже умышленная.
Вместо самопридуманной функции ПРОИЗВ, должна быть функция Excel ПРОИЗВЕД.
Может поэтому файл-пример не приложили?

Для форумчан выкладываю файл с обеими формулами.
« Последнее редактирование: 31.08.2018, 21:47:25 от boa »
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 990
Re: Упростить формулу
« Ответ #7 : 31.08.2018, 23:47:02 »

Цитировать
Ник ничем не отличается от Вашего
Основное отличие - Вы не думаете о тех, кто общается с Вами и может читать/произносить Ваш ник. Ник - для других...

О названии темы. Зайдет другой посетитель. Ему, тоже нужно подправить формулу, но другую (например, посчитать поголовье). Он будет заглядывать в такие вот темы, тратить время и уходить ни с чем. Опять - не думаете о тех, кто придет после Вас.
Название темы должно отражать суть задачи:
. Пример:
Посчитать в стаде серых баранов с проплешиной. Упростить формулу. Так понятнее?
Записан
 



Темы без ответов

30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 394
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1190
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1189
23.01.2018 13:46 Найти вероятность повторной покупки 1083
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1522
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1367
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1729
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 3480
15.03.2017 15:45 автозамена картинок PowerPoint 1975
11.03.2017 13:43 Изменить нумерацию страниц 2103





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.114 секунд. Запросов: 111.