Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Автор Тема: Поиск значения в другой таблице по частичному совпадению  (Прочитано 66 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Pterodahtil

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 26

День добрый.
Пример листа в скрепке. Смотрим столбец С. В ячейке С2 ищем наличие текста из столбца М. При условно-точном совпадении пишем соответствующее число из О.
Проблема в том, что искомый текст "Анализ отчетов о загрузке АТС и о ее свободных ресурсах (МО) (ежедн.)" а где мы ищем
"Задание #AT-1829272# Анализ отчетов о загрузке АТС и о ее свободных ресурсах (МО) (ежедн.) назначено на исполнение"
То есть в ячейке М помимо искомого текста ещё присутствует другой текст.
ВПР и ПОИСКПОЗ не подходит. Что нашёл в инете, строится на Если(если(если...) и настолько длинная форма получается, что не влезает.
Что можно придумать?

Спасибо.
« Последнее редактирование: 05.09.2018, 14:00:53 от vikttur »
Записан

Pelena

  • Постоялец
  • ***
  • Уважение: +35/-0
  • Оффлайн Оффлайн
  • Сообщений: 279

Здравствуйте.
Как вариант, если в столбце М значения не повторяются
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($M$2:$M$9;C2))*$O$2:$O$9)
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +48/-0
  • Оффлайн Оффлайн
  • Сообщений: 978

=ПРОСМОТР(2;1/(ПОИСК($M$2:$M$9;C2));$N$2:$N$9)
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 525

=ПРОСМОТР(;-ПОИСК(M$2:M$9;C2);P$2:P$9)
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Pterodahtil

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 26

Здравствуйте.
Как вариант, если в столбце М значения не повторяются
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($M$2:$M$9;C2))*$O$2:$O$9)

Спасибо!!
Записан
 



Темы без ответов

22.05.2018 11:38 Скрипт написать который допишет данные в файл 572
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 849
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 821
23.01.2018 13:46 Найти вероятность повторной покупки 778
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1060
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1033
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1347
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 2953
15.03.2017 15:45 автозамена картинок PowerPoint 1783
11.03.2017 13:43 Изменить нумерацию страниц 2013





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.101 секунд. Запросов: 105.