Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Автор Тема: Поиск значения в другой таблице по частичному совпадению  (Прочитано 268 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Pterodahtil

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 26

День добрый.
Пример листа в скрепке. Смотрим столбец С. В ячейке С2 ищем наличие текста из столбца М. При условно-точном совпадении пишем соответствующее число из О.
Проблема в том, что искомый текст "Анализ отчетов о загрузке АТС и о ее свободных ресурсах (МО) (ежедн.)" а где мы ищем
"Задание #AT-1829272# Анализ отчетов о загрузке АТС и о ее свободных ресурсах (МО) (ежедн.) назначено на исполнение"
То есть в ячейке М помимо искомого текста ещё присутствует другой текст.
ВПР и ПОИСКПОЗ не подходит. Что нашёл в инете, строится на Если(если(если...) и настолько длинная форма получается, что не влезает.
Что можно придумать?

Спасибо.
« Последнее редактирование: 05.09.2018, 14:00:53 от vikttur »
Записан

Pelena

  • Постоялец
  • ***
  • Уважение: +35/-0
  • Оффлайн Оффлайн
  • Сообщений: 281

Здравствуйте.
Как вариант, если в столбце М значения не повторяются
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($M$2:$M$9;C2))*$O$2:$O$9)
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 005

=ПРОСМОТР(2;1/(ПОИСК($M$2:$M$9;C2));$N$2:$N$9)
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 552

=ПРОСМОТР(;-ПОИСК(M$2:M$9;C2);P$2:P$9)
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Pterodahtil

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 26

Здравствуйте.
Как вариант, если в столбце М значения не повторяются
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($M$2:$M$9;C2))*$O$2:$O$9)

Спасибо!!
Записан
 



Темы без ответов

28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 210
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 562
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 402
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 535
20.01.2019 12:38 Все варианты частичного суммирования 679
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 540
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 974
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1759
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1805
23.01.2018 13:46 Найти вероятность повторной покупки 1621





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.112 секунд. Запросов: 105.