Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: Столбец, значения в который копируются со смещением  (Прочитано 120 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Anastasiaa

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Добрый день!

Очень надеюсь на помощь!

Нужно создать столбец с названиями города, значения в который будут возвращаться из ячейки соседнего столбца, каждую 61-ю строку значение меняется.
В примере растянула абсолютной ссылкой на ячейку, но в реальности речь идет о сотнях таких строк.

Спасибо!
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 990

Вряд ли ххх - одинаковые данные. А за них можно было бы зацепиться.
В В17:
=ЕСЛИ(ОСТАТ(СТРОКА(A61);61)=0;C4;ЕСЛИ(СЧЁТЕСЛИ($B$16:B16;B16)=48;"";B16))
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 542
  • Доброта спасет мир...

=ИНДЕКС(C3;ОТБР((СТРОКА()-4)/61;0)*61+4)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Anastasiaa

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Огромное спасибо!

=ИНДЕКС(C3;ОТБР((СТРОКА()-4)/61;0)*61+4)
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 990

Или пример кривой, или формула неправильно работает.
В примере четко видно, что строки с 49 до 61 должны быть пустые...
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 542
  • Доброта спасет мир...

Виктор, я не закладывал в формулу вывод пустого значения с 49 до 61

P.S. не "с 49 до 61" а с 0 по 12 или я то же что-то не так вижу
добавил в формулу
=IF(MOD((ROW()-4);61)<13;"";INDEX(C3;TRUNC((ROW()-4)/61;0)*61+4))
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 452
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1243
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1248
23.01.2018 13:46 Найти вероятность повторной покупки 1129
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1590
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1400
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1790
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 3573
15.03.2017 15:45 автозамена картинок PowerPoint 2030
11.03.2017 13:43 Изменить нумерацию страниц 2154





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.098 секунд. Запросов: 107.