Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Автор Тема: Столбец, значения в который копируются со смещением  (Прочитано 99 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Anastasiaa

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Добрый день!

Очень надеюсь на помощь!

Нужно создать столбец с названиями города, значения в который будут возвращаться из ячейки соседнего столбца, каждую 61-ю строку значение меняется.
В примере растянула абсолютной ссылкой на ячейку, но в реальности речь идет о сотнях таких строк.

Спасибо!
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +48/-0
  • Онлайн Онлайн
  • Сообщений: 987

Вряд ли ххх - одинаковые данные. А за них можно было бы зацепиться.
В В17:
=ЕСЛИ(ОСТАТ(СТРОКА(A61);61)=0;C4;ЕСЛИ(СЧЁТЕСЛИ($B$16:B16;B16)=48;"";B16))
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +31/-0
  • Оффлайн Оффлайн
  • Сообщений: 533
  • Доброта спасет мир...

=ИНДЕКС(C3;ОТБР((СТРОКА()-4)/61;0)*61+4)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Anastasiaa

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Огромное спасибо!

=ИНДЕКС(C3;ОТБР((СТРОКА()-4)/61;0)*61+4)
Записан

vikttur

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +48/-0
  • Онлайн Онлайн
  • Сообщений: 987

Или пример кривой, или формула неправильно работает.
В примере четко видно, что строки с 49 до 61 должны быть пустые...
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +31/-0
  • Оффлайн Оффлайн
  • Сообщений: 533
  • Доброта спасет мир...

Виктор, я не закладывал в формулу вывод пустого значения с 49 до 61

P.S. не "с 49 до 61" а с 0 по 12 или я то же что-то не так вижу
добавил в формулу
=IF(MOD((ROW()-4);61)<13;"";INDEX(C3;TRUNC((ROW()-4)/61;0)*61+4))
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 127
22.05.2018 11:38 Скрипт написать который допишет данные в файл 692
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 940
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 913
23.01.2018 13:46 Найти вероятность повторной покупки 857
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1194
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1114
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1443
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 3103
15.03.2017 15:45 автозамена картинок PowerPoint 1844





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.133 секунд. Запросов: 107.