Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Суммирование ячеек по диапазону дат с множеством условий  (Прочитано 173 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Lencha

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Уважаемые форумчане, доброе утро!
Прошу вашей помощи в решении следующей задачки:
Есть исходная таблица данных по бронированию мест в санатории. Из нее необходимо автоматически заполнить график загрузки корпусов.
Ранее вели учет по номерам и в графике по дням заполняли ФИО гостя, и если вдруг в один день был выезд и заезд, то график показывал пустую ячейку и закрашивал цветом, т.е. отражал накладку.
Но теперь задача поменялась - нужно суммировать количество человек находящихся в корпусе в указанный день без учета номеров.
Я никак не могу добиться правильного отражения в графике. Считает правильно в первый и последний день прибывания, а в промежутке нет.
Прилагаю файлик - лист график строки 3,4,5 новый вариант, который не считает промежутки, а в остальных старая формула, которая не считает накладки.
Помогите, пожалуйста, с решением. Спасибо.
Записан

Pelena

  • Постоялец
  • ***
  • Уважение: +35/-0
  • Оффлайн Оффлайн
  • Сообщений: 281

Здравствуйте.
Формула у Вас почти правильная. Немного диапазоны нужно поправить
=СУММПРОИЗВ((Путевки!$F$2:$F$21>=F$2)*(Путевки!$E$2:$E$21<=F$2)*(Путевки!$C$2:$C$21=$B3)*(Путевки!$G$2:$G$21))И в голубых ячейках можно немного покороче
=МАКС(СЧЁТЕСЛИ(F3:AJ3;">0")-E3;0)
« Последнее редактирование: 25.10.2018, 10:42:07 от Pelena »
Записан

Lencha

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Огромное вам спасибо!!!
Все работает)))
Записан
 



Темы без ответов

20.01.2019 12:38 Все варианты частичного суммирования 37
18.01.2019 23:35 Собрать отчет по актам выполненных работ 44
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 69
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 543
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1358
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1372
23.01.2018 13:46 Найти вероятность повторной покупки 1255
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 1726
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 1536
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 1930





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.134 секунд. Запросов: 101.