Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: как подогнать цену под нужную стоимость  (Прочитано 209 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Mirinda

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Здравствуйте всем! я обычный пользователь экселя, знакома только с простыми функциями этой программы. Сейчас появилась необходимость частого решения такой задачи: есть список товаров, цена, количество. нужно, чтобы программа изменила (на сотые доли) копейки в цене, чтобы подогнать сумму стоимостей под заданное число. Обычно, вручную подбирала, но убрать разницу в 1-6 копеек занимает много времени. Помогите, пожалуйста, как реализовать это более простым способом.
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 566
  • Доброта спасет мир...

Наверное так... =ОКРУГЛ(R14C8/СУММ(R2C4:R12C4)*RC4;2)или через Поиск решения
« Последнее редактирование: 01.01.2019, 22:04:46 от boa »
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Mirinda

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Спасибо, но это не совсем то, что нужно. По Вашей формуле идет коррекция стоимости по каждому товару, соответственно, стоимость 261,01 / 300 штук, получим цену,но, округлив в ней копейки до сотых 0,87, мы потеряем 1 копейку при пересчете обратно в стоимость.
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 566
  • Доброта спасет мир...

Я предполагал, что
это не совсем то
поэтому дал ссылку на "Поиск решения"
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Mirinda

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 3

Извините за непонятливость. Попробовала через подбор параметра. Подскажите, где у меня ошибка, т.к. не получается найти. Если изменять стоимость, то после запятой выдает от 4 до 7 знаков, а мне можно только 2 знака после запятой. Если стоимость округлить, то потом в цене будет минимум 3 знака после запятой...
« Последнее редактирование: 02.01.2019, 14:41:17 от Mirinda »
Записан

Ярослав Николаев

  • Новичок
  • *
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 6

А я бы не заморачивался и воспользовался обходным вариантом:
1. Все ячейки "стоимость" кроме последней, округляйте до двух знаков после запятой, типа =ОКРУГЛ(B2*C2;2)2. А вот последняя ячейка пусть из вашей итоговой суммы (которую вы, видимо, вводите руками) вычитает сумму всех ячеек пункта 1 =H14-СУММ(D2:D11)
Пример во вложении
Записан
 



Темы без ответов

05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 106
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 69
28.02.2019 10:21 Извлечение данных в новую таблицу Excel или преобразование в Word (избавление от 124
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 194
20.01.2019 12:38 Все варианты частичного суммирования 306
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 220
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 692
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1481
14.02.2018 10:11 Подготовить читабельную отчетность по платежам 1500
23.01.2018 13:46 Найти вероятность повторной покупки 1364





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.108 секунд. Запросов: 108.