Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: Сумирование массива по условию  (Прочитано 315 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Мария Прохорова

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2

Здравстуйте подскажите пожалуйста как выполнить следующие действия в exel.
Нужно просуммировать массив данных удовлетворяющих условию в столбце слева. Файл прилагаю. формула "суммесли" не работает. Только пожалуйста не надо писать простую формулу "сумм" с диапазоном суммируемых ячеек или выводить сумму по каждой строке в 1 столбец и складывать и т.д.
Здесь приведен урезанный формат данных, значений на самом деле очень много (к тому же столбцы будут добавляться...) и поэтому нужно чтобы суммировались все значения в диапазоне B:H, соответствующие определенному условию в столбце А (в файле указан пример).
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 552
Re: Сумирование массива по условию
« Ответ #1 : 13.01.2019, 18:40:51 »

Так нужно?
=СУММПРОИЗВ((A$2:A$9999=2)*Ч(+B$2:H$9999))
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 582
  • Доброта спасет мир...
Re: Сумирование массива по условию
« Ответ #2 : 13.01.2019, 19:06:04 »

Только пожалуйста не надо писать простую формулу "сумм" с диапазоном суммируемых ячеек
а почему нет?

=СУММ(ИНДЕКС(C2;ПОИСКПОЗ(RC11;C1;0)):ИНДЕКС(C8;ПОИСКПОЗ(RC11;C1;0)+СЧЁТЕСЛИ(C1;RC11)-1))следующая покороче, но волотильная.
=СУММ(СМЕЩ(R1C1;ПОИСКПОЗ(RC11;C1;0)-1;1;СЧЁТЕСЛИ(C1;RC11);7))в RC11 - критерий
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Мария Прохорова

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2
Re: Сумирование массива по условию
« Ответ #3 : 14.01.2019, 21:46:53 »

Да Все так. Спасибо ОГРОМНЕЙШЕЕ за помощь!!!!!!!!!!!!!!!!!!!!!!
Только не подскажите еще как быть если нужно суммировать не все столбцы массива, а только первые и последние. Например: столбцы B:E и стобец H. Просто опять таки если я дважды вбиваю формулу через знак "+" с учетом суммируемых диапазонов, он опять выдает 0.
Заранее спасибо.
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 582
  • Доброта спасет мир...
Re: Сумирование массива по условию
« Ответ #4 : 14.01.2019, 22:22:58 »

Александра
=СУММПРОИЗВ((C1=RC11)*Ч(+C2:C5))
+СУММПРОИЗВ((C1=RC11)*Ч(+C8))
и мои две
=СУММ(СМЕЩ(R1C1;ПОИСКПОЗ(RC11;C1;0)-1;1;СЧЁТЕСЛИ(C1;RC11);4))
+СУММ(СМЕЩ(R1C1;ПОИСКПОЗ(RC11;C1;0)-1;7;СЧЁТЕСЛИ(C1;RC11);1))
=СУММ(ИНДЕКС(C2;ПОИСКПОЗ(RC11;C1;0)):ИНДЕКС(C5;ПОИСКПОЗ(RC11;C1;0)+СЧЁТЕСЛИ(C1;RC11)-1))
+СУММ(ИНДЕКС(C8;ПОИСКПОЗ(RC11;C1;0)):ИНДЕКС(C8;ПОИСКПОЗ(RC11;C1;0)+СЧЁТЕСЛИ(C1;RC11)-1))
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 552
Re: Сумирование массива по условию
« Ответ #5 : 15.01.2019, 00:38:39 »

=СУММПРОИЗВ((A$2:A$9999=2)*(Ч(+B$2:H$9999)*{1;1;1;1;0;0;1}))
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995
 



Темы без ответов

18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 35
09.07.2019 20:39 Кредит с уменьшением периода выплат 62
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 348
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 659
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 470
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 607
20.01.2019 12:38 Все варианты частичного суммирования 751
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 615
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 1039
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 1831





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.122 секунд. Запросов: 107.