Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Автор Тема: Среднее значение по условию  (Прочитано 116 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Виктор С

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4

Здравствуйте, подскажите простую формулу.
Требуется вычислить среднее значение ячеек подходящих под условие >=0,1
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 010
Re: Среднее значение по условию
« Ответ #1 : 10.08.2019, 21:34:32 »

=СУММЕСЛИ(A1:A23;">=0,1")/СЧЕТЕСЛИ(A1:A23;">=0,1")
Записан

Виктор С

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4
Re: Среднее значение по условию
« Ответ #2 : 12.08.2019, 08:52:37 »

Ага , спасибо, логику понял. Сумму делим на количество ячеек.
Записан

Виктор С

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4
Re: Среднее значение по условию
« Ответ #3 : 19.08.2019, 11:30:21 »

Добрый день, есть тут у меня еще один примерчик. Требуется вычислить среднее время ячеек столбца 2 которые подходят под условие: смежная ячейка в столбце 1 >=0.1
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 010
Re: Среднее значение по условию
« Ответ #4 : 19.08.2019, 12:22:52 »

В СУММЕСЛИ можно задавать и диапазон условия, и диапазон суммирования
Записан

Виктор С

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 4
Re: Среднее значение по условию
« Ответ #5 : 19.08.2019, 14:12:35 »

Спасибо, разобрался. Когда раз в год этим занимаешься, во время процесса чувствуешь себя дураком))
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 010
Re: Среднее значение по условию
« Ответ #6 : 19.08.2019, 15:19:32 »

Зато после процесса появляется удовлетворение от полученного опыта )
Записан
 



Темы без ответов

09.08.2019 14:09 Макрос для заполнения таблиц через форму 143
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 156
09.07.2019 20:39 Кредит с уменьшением периода выплат 204
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 538
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 848
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 622
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 756
20.01.2019 12:38 Все варианты частичного суммирования 932
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 773
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 1183





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.119 секунд. Запросов: 110.