Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Автор Тема: Доп. вычисления в сводной таблице  (Прочитано 1835 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Strelec79

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 13

Помогите пожалуйста решить вопрос.
Емеется сводная таблица, в которой данные отсортированы по дате, мне нужно добавить столбец "Изменения", в котором бы отображалось изменение значений текущей даты от предыдущей.
Например:
Дата         Значение   Изменения
06.08.2009       8   
07.08.2009       5              -3
08.08.2009       3              -2
09.08.2009       9               6
 Спасибо.
Записан

kimtan

  • Старожил
  • ****
  • Уважение: +42/-0
  • Оффлайн Оффлайн
  • Сообщений: 535
Re: Доп. вычисления в сводной таблице
« Ответ #1 : 09.08.2009, 15:46:44 »

Если "Изменения" это столбец C, тогда в C2  =ЕСЛИ(И(B2<>"";ЕЧИСЛО(B1));B2-B1;"")
Записан
Webmoney: E350157549801 Z116603216205 R268084006579

Strelec79

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 13
Re: Доп. вычисления в сводной таблице
« Ответ #2 : 09.08.2009, 18:36:02 »

Только у меня же СВОДНАЯ ТАБЛИЦА. Эту формулу можно ввести в сводную таблицу? Каким образом? Как вычисляемое поле или обьект?, кстати функция вычисляемый обьект у меня все время неактивная, почему?
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 556
Re: Доп. вычисления в сводной таблице
« Ответ #3 : 09.08.2009, 21:52:22 »

Без всяких формул.
Посмотрите в макете сводной таблицы способ вычисления поля "Изменение"
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Strelec79

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 13
Re: Доп. вычисления в сводной таблице
« Ответ #4 : 09.08.2009, 23:29:12 »

Я понял !!! Спасибо _Boroda_ !!! Все получилось!!!
Записан
 



Темы без ответов

27.05.2022 14:38 конструкция из Shape на VBA на листе Excel 463
09.08.2019 14:09 Макрос для заполнения таблиц через форму 5295
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4652
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 6258
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3346
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 5171
15.03.2017 15:45 автозамена картинок PowerPoint 4073
11.03.2017 13:43 Изменить нумерацию страниц 4013
07.02.2017 18:43 Блокировка ячеек по наступлению даты 3135
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3632





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.111 секунд. Запросов: 102.