Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Автор Тема: Редакция ЖО  (Прочитано 2563 раз)

0 Пользователей и 1 Гость просматривают эту тему.

iron priest

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +34/-0
  • Оффлайн Оффлайн
  • Сообщений: 766
  • почётный флудераст
Редакция ЖО
« : 08.12.2009, 10:10:55 »

Хочу всетаки прилепить в обработку Алексея ЖО единицу измерения. решил уменьшить объем до выгрузки только ТМЦ. Изначально поэкспериментировал и сделал выгрузку справочника ТМЦ с указание единицы измерения:

Процедура Сформировать()
Таб=создатьобъект("Таблица");
Ит=создатьобъект("Справочник.ТМЦ");
ит.выбратьэлементы();
таб.вывестисекцию("секц");
Пока Ит.Получитьэлемент()=1 цикл
товар=ит.ПолнНаименование;
ед=ит.БазоваяЕдиница;
таб.вывестисекцию("секц");
//пока Ит.получитьэлемент()>0 цикл
// товар=ит.ПолнНаименование;
// ед=ит.БазоваяЕдиница;
КонецЦикла;


Таб.Показать();
КонецПроцедуры

и решил раз так все просто, то добавлю в код необходимые строки, вот что получилось
Процедура Сформировать()
Таб=СоздатьОбъект("Таблица");
Ит=СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.ТМЦ,,,);
Ит.ВключатьСубсчета(-1);
Ит.ВыполнитьЗапрос(НачДата, КонДата, ,,, 1,, 5);
ай=создатьобъект("Справочник.ТМЦ");
ай.выбратьэлементы();
Таб.ВывестиСекцию("Секция");
Ит.ВыбратьСчета();
пока ай.получитьэлемент()=1 цикл
ед=ай.БазоваяЕдиница;
    КонецЦикла;
Пока Ит.ПолучитьСчет()=1 Цикл;
Сбк=Ит.Счет.КоличествоСубконто();
Если Сбк = 0 Тогда;
ПолнНаименование=Ит.Счет.Наименование;   
дебск=ит.скд();
кредск=ит.скк();
дебсккол=ит.скд("К");
кредсккол=ит.скк("К");
дебсн=ит.снд();
кредсн=ит.снк();
дебснкол=ит.снд("К");
кредснкол=ит.снк("К");
Таб.ВывестиСекцию("Секция");

Иначе
Ит.ВыбратьСубконто(1,,,,,,1);
Пока Ит.ПолучитьСубконто() = 1 Цикл
ПолнНаименование=Ит.субконто(1);
дебск=ит.скд();
кредск=ит.скк();
дебсккол=ит.скд("К");
кредсккол=ит.скк("К");
дебсн=ит.снд();
кредсн=ит.снк();
дебснкол=ит.снд("К");
кредснкол=ит.снк("К");
Таб.ВывестиСекцию("Секция");
КонецЦикла;
КонецЕсли;
КонецЦикла;
Таб.Показать();
КонецПроцедуры

но 1с мне выгружает все ТМЦ с единицей измерения "шт.". залез на форум программистов 1с, но они по данной теме ничего конкретного не предлагают. Может кто-то подскажет что к чему.

ЗЫ: на форуме сказали обратиться еще к справочнику "Единицы"  :-\



Записан

iron priest

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +34/-0
  • Оффлайн Оффлайн
  • Сообщений: 766
  • почётный флудераст
Re: Редакция ЖО
« Ответ #1 : 16.12.2009, 16:04:14 »

сделал немного другую выгрузку по всем ТМЦ. может кому пригодится
Записан

Шпец Докапыч

  • Ветеран
  • *****
  • Уважение: +189/-4
  • Оффлайн Оффлайн
  • Сообщений: 1 918
  • ОБЛАДАТЕЛЬ УНИКАЛЬНЫХ НАВЫКОВ!!! :)
Re: Редакция ЖО
« Ответ #2 : 24.12.2009, 06:55:03 »

Попробовал обработочку:
ИТ.ИспользоватьСубконто("ТМЦ");
{C:\ВЫГРУЗКА ТМЦ.ERT(7)}: Число фильтров субконто превысило допустимое значение!

Может что-то можно подкрутить?
Конфигурация: Штрих-М: Торговое предприятие PROF 4x.
Записан
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

iron priest

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +34/-0
  • Оффлайн Оффлайн
  • Сообщений: 766
  • почётный флудераст
Re: Редакция ЖО
« Ответ #3 : 13.01.2010, 23:53:28 »

бог его знает, нада на работе подывыться

ЗЫ: первый раз такую конфу слышу :(


а как у вас в конфигураторе субконто товары называются? у меня ТМЦ, у вас может както иначе?
« Последнее редактирование: 14.01.2010, 17:13:13 от iron priest »
Записан
 



Темы без ответов

06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 277
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 402
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 1401
15.03.2017 15:45 автозамена картинок PowerPoint 996
11.03.2017 13:43 Изменить нумерацию страниц 1222
18.02.2017 11:31 Изменить ввод данных помогите...из столбца в таблицу. 1269
07.02.2017 18:43 Блокировка ячеек по наступлению даты 1438
12.12.2016 23:39 Расчет заказа по формуле, или использовать [abbr=Вводится через Ctrl+Shift+Enter]формулу массива[/abbr] 1505
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 2001
07.08.2016 17:33 Определить нумерацию как элемент стиля 2183





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.084 секунд. Запросов: 95.