Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Читайте новые сообщения форума форума в RRS-агрегаторах

Автор Тема: Найти одинаковое и скопировать строку  (Прочитано 1234 раз)

0 Пользователей и 1 Гость просматривают эту тему.

umaks600

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Добрый День! Подскажите пожалуйста какой будет макрос данного примера. Пример во вложении.
Записан

cheshiki1

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +92/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 006

макрос  здесь не нужен. обычная формула
=ВПР(A1;$C$1:$D$10;2;)
Записан

umaks600

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Спасибо большое
Записан

umaks600

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Что то не получается нет данных пишет можете глянуть в чем ошибка..
Записан

cheshiki1

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +92/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 006

у вас в столбце А применен Формат ячейки - это всего лишь визуальное отображение (мираж).
для данного файла нужно так.
=ВПР(ТЕКСТ(A1;"00000000");таб;2;)
Записан

umaks600

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Вот спасибо добрый человек!!!
Записан

cheshiki1

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +92/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 006

Если значение аргумента «интервальный_просмотр» — ЛОЖЬ, а аргумент «искомое_значение» представляет собой текст, то в аргументе «искомое_значение» допускается использование подстановочных знаков: вопросительного знака (?) и звездочки (*). Вопросительный знак соответствует любому знаку; звездочка — любой последовательности знаков. Чтобы найти сами эти знаки, следует поставить перед ними знак тильды (~).
=ВПР("*"&A1;таб;2;)так по короче будет.
Записан

umaks600

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Назрел следующий вопрос)) Щас скопировал столбик который получился и хочу вставить в другую книгу или лист но копируются не полученные цифры а формулы как исправить не подскажите??   Все сори разобрался....
на будущее 1 вопрос одна тема
« Последнее редактирование: 04.08.2016, 09:28:19 от cheshiki1 »
Записан
 



Темы без ответов

27.05.2022 14:38 конструкция из Shape на VBA на листе Excel 463
09.08.2019 14:09 Макрос для заполнения таблиц через форму 5295
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4653
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 6259
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3346
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 5172
15.03.2017 15:45 автозамена картинок PowerPoint 4073
11.03.2017 13:43 Изменить нумерацию страниц 4013
07.02.2017 18:43 Блокировка ячеек по наступлению даты 3135
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3633





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.129 секунд. Запросов: 112.