Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Автоматизировать заполнение таблицы по условию  (Прочитано 4529 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Sveta

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Здравствуйте=) я новичок и мне сразу дали непростое задание. Помогите пожалуйста разобраться как это сделать.
Необходимо чтобы таблица на листе1 автоматически заполнялась при заполнение таблицы на листе2. Но на листе1  должны отображаться данные только определенных столбцов (во вложении они выделены желтым цветом) и по условию, что в таблице на листе2  Количество>0 (количество-это столбец на листе2).
Как должно все выглядеть можно посмотреть во вложении.
Помогите пожалуйста!!!!!!
« Последнее редактирование: 01.02.2016, 20:25:56 от Sveta »
Записан

IKor

  • Старожил
  • ****
  • Уважение: +49/-0
  • Оффлайн Оффлайн
  • Сообщений: 902

2 Sveta

Пожалуйста, посмотрите прилагаемый файл.
В таблице на листе 1 добавлены формулы, возвращающие значения из строк с ненулевым количеством из таблицы листа 2.
Для работы формул потребовалось добавить вспомогательный столбец на лист 2 (он выделен цветом).
Кроме того обратите внимание на то, что значения в оригинальном столбце количество имеют не числовые, а текстовые значения - поэтому их потребовалось преобразовать в число.
При необходимости Вы можете скопировать преобразованные значения и вставить_как_значение в столбец количество => а затем перенастроить вспомогательный столбец.

Будут вопросы - обращайтесь :)
Записан

Sveta

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 11

Большое Спасибо!!!!!!!!!
Записан

zs5

  • Постоялец
  • ***
  • Уважение: +4/-0
  • Оффлайн Оффлайн
  • Сообщений: 160

один лист; без преобразования текстовых значений, указанных в примере, без вспомогательных столбцов:
=ЕСЛИ(СТРОКА(A7)=7; ИНДЕКС($A$7:$J$14;ПОИСКПОЗ("1";D7:$D$14;0);1);ЕСЛИ(СЧЁТЗ($P$3:P3)<СЧЁТЕСЛИ(D7:$D$14;"1")-1;ИНДЕКС(ИНДЕКС(СМЕЩ(Лист2!$D$7:$D$14;ПОИСКПОЗ(M14;Лист2!$A$7:$A$14;0);0):Лист2!$D$14;1;1):$A$14;ПОИСКПОЗ("1";ИНДЕКС(СМЕЩ(Лист2!$D$7:$D$14;ПОИСКПОЗ(M14;Лист2!$A$7:$A$14;0);0):Лист2!$D$14;1;1):Лист2!$D$14;0);1);""))
Записан
 



Темы без ответов

27.05.2022 14:38 конструкция из Shape 287
09.08.2019 14:09 Макрос для заполнения таблиц через форму 5174
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4556
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 6137
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3239
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 5055
15.03.2017 15:45 автозамена картинок PowerPoint 3968
11.03.2017 13:43 Изменить нумерацию страниц 3906
07.02.2017 18:43 Блокировка ячеек по наступлению даты 3025
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3518





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.101 секунд. Запросов: 103.