Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Автор Тема: Создание сложной формулы  (Прочитано 4557 раз)

0 Пользователей и 1 Гость просматривают эту тему.

infowater

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2
Создание сложной формулы
« : 09.08.2009, 03:19:52 »

[size=18]Добрый день![/size]

На днях решил упростить жизнь своему инженеру и создать в EXCEL систему расчетов, чтобы вводишь 2 – 3 исходных параметра и получаешь полностью подобранный вариант оборудования.
Сначала все шло нормально, но потом знаний катастрофически перестало хватать и полез я в книги и интернет. На некоторые вопросы я нашел ответы, на некоторые нет. Пришлось поэкспериментировать. Но когда я подошел к финалу – тут-то я столкнулся с проблемой ответы на которую я не где не смог найти.
В сущности, задача такая:
1. Человек вводит 2 параметра, в нашем примере:
вносим какие-то данные – 90 + вот эти – 2 = Получим – 92
2. у нас есть таблица с готовыми параметрами. Мы сравниваем полученный результат (п.1 - 92) с первым столбцом нашей таблицы и результат попадает в 5-тый столбец таблицы. Если параметр из п.1 лежит в пределах наших формул 1 и 2, то пишется текст из 4-го столбца таблицы, если нет – то ---.
3. Теперь самое главное. Нас интересует название аппарата, а не ---. Пробуем создать формулу 3 и после введения 8-ми аргументов (с баллон 6х35 по баллон 16х65), 9-тый уже не считается.
4. Тогда создаем аналогичную 3-тьей формулу 4 с последующим расчетом показателей ячеек (с баллона 18х65 по баллон 48х72) и получаем что она начинает работать после того как аргумент попадает в ячейки с Е12 по Е18.
5. Затем все суммируется в ячейке Е23.

Скрин здесь:

Файл здесь:
http://rapidshare.com/files/265259168/_____.xls.html
или
http://letitbit.net/download/1964.108d1d8989264ad495b70c988/_____.xls.html - кто не в курсе как качать бесплатно с letitbit.net вот здесь картинка:

и


Вопрос ко всем кто знает:

1. Какая формула должна быть, чтобы исключить ячейки Е21 и Е22?

2. Как можно упростить формулы?

Заранее благодарю.

P.S. Просьба продублировать ответ на e-mail: infowater@mail.ru
Записан

DV68

  • Постоялец
  • ***
  • Уважение: +36/-0
  • Оффлайн Оффлайн
  • Сообщений: 373
Re: Создание сложной формулы
« Ответ #1 : 09.08.2009, 11:01:30 »

Вместо всех этих формул воспользуйся
=ИНДЕКС(A4:D18;ПОИСКПОЗ(B3;A4:A18;1)+1;4)
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 587
  • Доброта спасет мир...
Re: Создание сложной формулы
« Ответ #2 : 09.08.2009, 21:07:03 »

или ВПР
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

infowater

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 2
Re: Создание сложной формулы
« Ответ #3 : 09.08.2009, 21:37:40 »

Вместо всех этих формул воспользуйся
=ИНДЕКС(A4:D18;ПОИСКПОЗ(B3;A4:A18;1)+1;4)

Большое спасибо теперь все получилось!!! :D
Записан
 



Темы без ответов

09.08.2019 14:09 Макрос для заполнения таблиц через форму 142
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 156
09.07.2019 20:39 Кредит с уменьшением периода выплат 203
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 537
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 848
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 622
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 755
20.01.2019 12:38 Все варианты частичного суммирования 931
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 772
30.09.2018 10:24 Расчет процентов за определенный период (месяц) с учетом изменений и платежей 1182





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.104 секунд. Запросов: 107.