Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Автор Тема: суммирование по нескольким критериям  (Прочитано 983 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Jim

  • Постоялец
  • ***
  • Уважение: +0/-1
  • Оффлайн Оффлайн
  • Сообщений: 269
    • Сайт клуба Друзья

всем привет!

заранее извиняюсь, понимаю что такая тема была, но конкретно к задаче не смог подставить формулы.

необходимо посчитать сумму по нескольким критериям без дополнительных столбцов и без дополнительных формул. всё решение необходимо одной формулой.

см пример во вложении.
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +50/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 015

=СУММЕСЛИ(A2:A6;G2;B2:B6)+СУММЕСЛИ(A2:A6;G3;B2:B6)
формула массива:
=СУММ(ЕСЛИ(A2:A6=ТРАНСП(G2:G3);B2:B6))
Записан

Czeslaw

  • Пользователь
  • **
  • Уважение: +7/-0
  • Оффлайн Оффлайн
  • Сообщений: 83

Мне кажется, что можно применить и такую формулу:
=SUMPRODUCT(((A2:A6=G2)+(A2:A6=G3))*B2:B6)
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +50/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 015

Если для 2-3 значений, лучше несколько СУММЕСЛИ, формула легче в вычислениях.
Если значений много, советую возле каждого из них СУММЕСЛИ, и итоговая - обычная СУММ. Не стоит отвергать доп. столбцы/строки. Их можно спрятать, но доп. формулы во многих случаях намного облегчают вычисления.
Записан
 



Темы без ответов

24.01.2020 14:03 На диаграмме Ганта несоответствие оси Y 1397
09.08.2019 14:09 Макрос для заполнения таблиц через форму 3166
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 2778
09.07.2019 20:39 Кредит с уменьшением периода выплат 2878
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 3615
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 3473
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 3227
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 3429
20.01.2019 12:38 Все варианты частичного суммирования 3548
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 2870





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.099 секунд. Запросов: 100.