Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Автор Тема: Расчет по замене букв на цифры  (Прочитано 888 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Mish

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 15

Добрый день. Требуется расчитать з.п., (в первой колонке листа "З.П.). Стоимость каждого буквенного выражения на листе "Тариф".
У "Иванова" считает правильно, но при клонировании формулы вниз для других работников, формулы сбивается(((
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 594
  • Доброта спасет мир...
Re: Расчет по замене букв на цифры
« Ответ #1 : 19.08.2019, 14:03:54 »

Здравствуйте,
просто диапазон с листа Тариф надо фризить, что бы он не съезжал при копировании.
=SUMPRODUCT((C3:FG3=Тариф!A$1:A$14)*Тариф!B$1:B$14)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Mish

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 15
Re: Расчет по замене букв на цифры
« Ответ #2 : 19.08.2019, 14:17:02 »

В НОВОМ ЭКСЕЛЕ ФОРМУЛА ВЫГЛЯДИТ ВОТ ТАК: =СУММПРОИЗВ((RC[2]:RC[162]=Тариф!R[-2]C:R[11]C)*Тариф!R[-2]C[1]:R[11]C[1])
И Я НЕ ПОЙМУ КУДА НАДО ВОТКНУТЬ "$"
Записан

Mish

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 15
Re: Расчет по замене букв на цифры
« Ответ #3 : 19.08.2019, 14:25:00 »

и когда вставляю знак $, эксель ругается
Записан

_Boroda_

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +415/-0
  • Оффлайн Оффлайн
  • Сообщений: 2 556
Re: Расчет по замене букв на цифры
« Ответ #4 : 19.08.2019, 14:29:10 »

Перейдите в тип ссылок А1
Файл - Параметры - Формулы - снимите галку "Стиль ссылок R1C1"
 
И вот справку почитайте по поводу абсолютных и относительных ссылок
https://support.office.com/ru-ru/article/%D0%98%D1%81%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5-%D0%BE%D1%82%D0%BD%D0%BE%D1%81%D0%B8%D1%82%D0%B5%D0%BB%D1%8C%D0%BD%D1%8B%D1%85-%D0%B8-%D0%B0%D0%B1%D1%81%D0%BE%D0%BB%D1%8E%D1%82%D0%BD%D1%8B%D1%85-%D1%81%D1%81%D1%8B%D0%BB%D0%BE%D0%BA-981f5871-7864-42cc-b3f0-41ffa10cc6fc


В RC-стиле это будет так
=СУММПРОИЗВ((RC[2]:RC[162]=Тариф!R1C:R14C)*Тариф!R1C[1]:R14C[1])
« Последнее редактирование: 19.08.2019, 14:34:49 от _Boroda_ »
Записан
Скажи мне, кудесник, любимец ба’гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Mish

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 15
Re: Расчет по замене букв на цифры
« Ответ #5 : 19.08.2019, 14:57:17 »

Спасибо большое, помогло!
Записан
 



Темы без ответов

24.01.2020 14:03 На диаграмме Ганта несоответствие оси Y 1132
09.08.2019 14:09 Макрос для заполнения таблиц через форму 2880
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 2498
09.07.2019 20:39 Кредит с уменьшением периода выплат 2594
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 3306
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 3199
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 2960
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 3122
20.01.2019 12:38 Все варианты частичного суммирования 3280
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 2629





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.102 секунд. Запросов: 94.