Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Повторяющиеся значения на разных листах.  (Прочитано 1434 раз)

0 Пользователей и 1 Гость просматривают эту тему.

arti8181

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Ребята подскажите пожалуйста. Имеются числовые значения на листе 1. Имеются также числовые значения на листе 2. Как сделать так, чтобы на листе 1 подсвечивались значения, которые  дублируются со значениями на листе 2
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 594
  • Доброта спасет мир...

Для нужного диапазона добавьте условное_форматирование с формулой
=IFERROR(MATCH(A3;Лист2!$A:$A;0);0)<>0
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

arti8181

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

поясните пожалуйста как сделать, что то я не понял. как мне добавить диапозон?
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 594
  • Доброта спасет мир...

Измените диапазон поиска(например: Лист2!$A:$C) в функции match(ПОИСКПОЗ)
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

arti8181

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Извените но я совсем запутался. Скачал Ваш пример, там все нормально но стоит формула =ЕСЛИОШИБКА(ПОИСКПОЗ(A1;Лист2!$A:$A;0);0)<>0
А если набрать формулу =IFERROR(MATCH(A3;Лист2!$A:$A;0);0)<>0 то ничего не работает. 
Какую мне все таки написать формулу, чтобы я ставил значения в любые ячейки и в любой столбец листа2, а на листе 1 окрашивались значения, если дублируются с листом 2.
Помогите плиз очень нужно
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +50/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 015

Нужно показывать в файле, что там не работает.
Цитировать
чтобы я ставил значения в любые ячейки и в любой столбец листа2...
условное_форматирование, заданное для большого диапазона, может тормозить расчеты.

Цитировать
Измените диапазон поиска(например: Лист2!$A:$C)
Не учите плохому )
Не нужно задавать для диапазона весь столбец, тем более - для условного форматирования! Если функция не найдет нужного, она будет молотить ВСЕ ячейки. Если нельзя определить диапазон заранее, задать его размер с запасом.

Записан

arti8181

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5

Так все же. в итоге ничего не получилось. 314
-570 не закрасился, хотя дублируется
Записан

vikttur

  • Глобальный модератор
  • Ветеран
  • *****
  • Уважение: +50/-0
  • Оффлайн Оффлайн
  • Сообщений: 1 015

Так Вы же ищете ТОЛЬКО в столбце А. Если снять закрепление диапазона (Лист2!$A:$A Лист2!A:A), то значения будут сравниваться в столбцах, но Вам нужно не это. Вы хотите искать дубли на всем листе. А ПОИСКПОЗ работает только с одним вектором.
И еще раз - не грузите вычисления целыми столбцами в диапазонах.
=СЧЁТЕСЛИ(Лист2!$A$1:$S$100;A1)СЧЕТЕСЛИ умеет определять пользовательский диапазон, но как это работает в УФ, не знаю. Не рискуйте.
Записан

arti8181

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 5


Большое спасибо, очень выручили
« Последнее редактирование: 26.08.2019, 23:10:56 от vikttur »
Записан

boa

  • Глобальный модератор
  • Старожил
  • *****
  • Уважение: +32/-0
  • Оффлайн Оффлайн
  • Сообщений: 594
  • Доброта спасет мир...

Не учите плохому )
виноват, каюсь, )
сегодня был напряженный день и некогда было "разжовывать" и "наставлять"...

я когда заглянул в исходник..., вообще был в шоке, поэтому и дал ответ в стиле автора...
Записан
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра
 



Темы без ответов

24.01.2020 14:03 На диаграмме Ганта несоответствие оси Y 1132
09.08.2019 14:09 Макрос для заполнения таблиц через форму 2879
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 2497
09.07.2019 20:39 Кредит с уменьшением периода выплат 2594
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 3306
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 3199
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 2959
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 3122
20.01.2019 12:38 Все варианты частичного суммирования 3280
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 2628





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.114 секунд. Запросов: 102.