Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Автор Тема: Значение из ячейки по формуле из другой ячейки  (Прочитано 744 раз)

0 Пользователей и 1 Гость просматривают эту тему.

sbm78

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 1

Подскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.

т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее
значения могут повторяться, поиском не получится
« Последнее редактирование: 15.10.2021, 22:41:35 от sbm78 »
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +341/-0
  • Онлайн Онлайн
  • Сообщений: 3 037
    • Мир Excel

Здравствуйте

Для вашего примера:=ИНДЕКС(Лист1!A$1:C$7;ПРАВБ(Ф.ТЕКСТ(A2);ДЛСТР(Ф.ТЕКСТ(A2))-8);КОДСИМВ(ПСТР(Ф.ТЕКСТ(A2);ПОИСК("!";Ф.ТЕКСТ(A2))+1;1))-64-2)
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

09.08.2019 14:09 Макрос для заполнения таблиц через форму 5021
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4433
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 5993
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3125
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 4933
15.03.2017 15:45 автозамена картинок PowerPoint 3855
11.03.2017 13:43 Изменить нумерацию страниц 3781
07.02.2017 18:43 Блокировка ячеек по наступлению даты 2896
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3400
07.08.2016 17:33 Определить нумерацию как элемент стиля 3609





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.094 секунд. Запросов: 87.