Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Автор Тема: Значение из ячейки по формуле из другой ячейки  (Прочитано 580 раз)

0 Пользователей и 1 Гость просматривают эту тему.

sbm78

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 1

Подскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.

т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее
значения могут повторяться, поиском не получится
« Последнее редактирование: 15.10.2021, 22:41:35 от sbm78 »
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +341/-0
  • Оффлайн Оффлайн
  • Сообщений: 3 017
    • Мир Excel

Здравствуйте

Для вашего примера:=ИНДЕКС(Лист1!A$1:C$7;ПРАВБ(Ф.ТЕКСТ(A2);ДЛСТР(Ф.ТЕКСТ(A2))-8);КОДСИМВ(ПСТР(Ф.ТЕКСТ(A2);ПОИСК("!";Ф.ТЕКСТ(A2))+1;1))-64-2)
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

09.08.2019 14:09 Макрос для заполнения таблиц через форму 4556
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4082
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 5573
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 4491
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 5587
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 2788
23.01.2018 13:46 Найти вероятность повторной покупки 2564
12.01.2018 23:56 Сделать отчет на Power BI (Dashboard) 3551
06.09.2017 10:43 Solver VBA не решает гиперболическое уравнение, но при этом решает гармоническое 2439
17.08.2017 12:15 Гиперссылка и фильтр одновременно макрос 2884





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.148 секунд. Запросов: 100.