Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Автор Тема: Значение из ячейки по формуле из другой ячейки  (Прочитано 363 раз)

0 Пользователей и 1 Гость просматривают эту тему.

sbm78

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 1

Подскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.

т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее
значения могут повторяться, поиском не получится
« Последнее редактирование: 15.10.2021, 22:41:35 от sbm78 »
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +341/-0
  • Оффлайн Оффлайн
  • Сообщений: 3 004
    • Мир Excel

Здравствуйте

Для вашего примера:=ИНДЕКС(Лист1!A$1:C$7;ПРАВБ(Ф.ТЕКСТ(A2);ДЛСТР(Ф.ТЕКСТ(A2))-8);КОДСИМВ(ПСТР(Ф.ТЕКСТ(A2);ПОИСК("!";Ф.ТЕКСТ(A2))+1;1))-64-2)
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

24.01.2020 14:03 На диаграмме Ганта несоответствие оси Y 2736
09.08.2019 14:09 Макрос для заполнения таблиц через форму 3961
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 3583
09.07.2019 20:39 Кредит с уменьшением периода выплат 3601
28.05.2019 21:09 Сделать несколько скриптов для рабочей таблицы 4919
05.03.2019 17:00 Последовательный вывод таблиц Excel в один документ Word без шаблона 4311
05.03.2019 09:29 Нежелательные изменение размеров колонтитула при редактировании 4031
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 5070
20.01.2019 12:38 Все варианты частичного суммирования 4259
13.01.2019 12:24 Заполнение диапазона числами - в виде кластеров 3769





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.1 секунд. Запросов: 100.