Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: Значение из ячейки по формуле из другой ячейки  (Прочитано 752 раз)

0 Пользователей и 1 Гость просматривают эту тему.

sbm78

  • Новичок
  • *
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 1

Подскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.

т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее
значения могут повторяться, поиском не получится
« Последнее редактирование: 15.10.2021, 22:41:35 от sbm78 »
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +341/-0
  • Оффлайн Оффлайн
  • Сообщений: 3 038
    • Мир Excel

Здравствуйте

Для вашего примера:=ИНДЕКС(Лист1!A$1:C$7;ПРАВБ(Ф.ТЕКСТ(A2);ДЛСТР(Ф.ТЕКСТ(A2))-8);КОДСИМВ(ПСТР(Ф.ТЕКСТ(A2);ПОИСК("!";Ф.ТЕКСТ(A2))+1;1))-64-2)
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390
 



Темы без ответов

27.05.2022 14:38 конструкция из Shape 68
09.08.2019 14:09 Макрос для заполнения таблиц через форму 5032
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4442
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 6002
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3142
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 4939
15.03.2017 15:45 автозамена картинок PowerPoint 3862
11.03.2017 13:43 Изменить нумерацию страниц 3789
07.02.2017 18:43 Блокировка ячеек по наступлению даты 2902
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3408





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.091 секунд. Запросов: 96.