Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Автор Тема: Счет значений между двумя датами  (Прочитано 424 раз)

0 Пользователей и 1 Гость просматривают эту тему.

alfatboy

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 26

Добрый день!
Нужна помощь.
В таблице необходимо подсчитать количество значений за определенный период между двумя конкретными датами (выделены красным).
В ст.А значения
В ст.В даты
В ст.D прописал формулу, но расчет ведется неверно.
Отчетный период указан в ст.E и ст.F.
Образец во вложении.
Перевод в формат "умной таблице" не подходит.
« Последнее редактирование: 10.02.2022, 13:22:48 от alfatboy »
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +341/-0
  • Оффлайн Оффлайн
  • Сообщений: 3 039
    • Мир Excel
Re: Счет значений между двумя датами
« Ответ #1 : 10.02.2022, 14:24:16 »

Здравствуйте

Сколько должно получиться в примере и почему?
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390

alfatboy

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 26
Re: Счет значений между двумя датами
« Ответ #2 : 10.02.2022, 14:43:11 »

В примере в столбце А "Значения" между датами 02.02.2022 и 08.02.2022 должно получиться 14.
Счет должен быть количества ячеек между датами.
Вместо цифр в ст.А "Значения" указываются разные данные, мне нужно посчитать именно их количество.
Записан

Serge 007

  • Администратор
  • Ветеран
  • *****
  • Уважение: +341/-0
  • Оффлайн Оффлайн
  • Сообщений: 3 039
    • Мир Excel
Re: Счет значений между двумя датами
« Ответ #3 : 10.02.2022, 15:08:09 »

...между датами 02.02.2022 и 08.02.2022 должно получиться 14...
=СУММПРОИЗВ((B2:B25>=E2)*(B2:B25<=F2)*(A2:A25<>""))
Записан
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Яндекс-деньги: 41001419691823 | WMR:126292472390

alfatboy

  • Пользователь
  • **
  • Уважение: +1/-0
  • Оффлайн Оффлайн
  • Сообщений: 26
Re: Счет значений между двумя датами
« Ответ #4 : 10.02.2022, 15:52:56 »

Огромное спасибо!
Добавил еще несколько условий для подсчета, все работает отлично!!!
Записан
 



Темы без ответов

27.05.2022 14:38 конструкция из Shape на VBA на листе Excel 432
09.08.2019 14:09 Макрос для заполнения таблиц через форму 5273
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4643
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 6248
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3329
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 5147
15.03.2017 15:45 автозамена картинок PowerPoint 4056
11.03.2017 13:43 Изменить нумерацию страниц 3995
07.02.2017 18:43 Блокировка ячеек по наступлению даты 3118
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3619





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.103 секунд. Запросов: 105.