Профессиональные приемы работы в Microsoft Excel

Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск  

Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Автор Тема: Сортировка списка  (Прочитано 1432 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Олег Корзников

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 55
Сортировка списка
« : 12.11.2009, 20:32:09 »

Уважаемые специалисты
Помогите пожалуйста с формулой
Есть список с множеством фамилий и инициалов
Требуется чтобы напротив строки с фамилией стояла цифра обозначающая порядковый номер при сортировке по алфавиту
Например:
3     Юдин Г.М.
1     Абрамович И.И.
2     Пупкин Б.Ж.
Записан
NULL

ZORRO2005

  • Старожил
  • ****
  • Уважение: +91/-0
  • Оффлайн Оффлайн
  • Сообщений: 851
Re: Сортировка списка
« Ответ #1 : 12.11.2009, 21:36:13 »

Олег Корзников,
Смотрите вложение.
Записан

Олег Корзников

  • Пользователь
  • **
  • Уважение: +0/-0
  • Оффлайн Оффлайн
  • Сообщений: 55
Re: Сортировка списка
« Ответ #2 : 12.11.2009, 23:05:50 »

Олег Корзников,
Смотрите вложение.
А можно по подробнее по формуле объяснить
зачем два минуса и т.д.
заранее благодарен
Записан
NULL

ZORRO2005

  • Старожил
  • ****
  • Уважение: +91/-0
  • Оффлайн Оффлайн
  • Сообщений: 851
Re: Сортировка списка
« Ответ #3 : 12.11.2009, 23:19:11 »

"--" превращает ИСТИНА в 1.
Вот еще вариант.
В С3:
=СУММПРОИЗВ((B3>=$B$3:$B$8)*1)
и тянем вниз
« Последнее редактирование: 12.11.2009, 23:21:15 от ZORRO2005 »
Записан
 



Темы без ответов

27.05.2022 14:38 конструкция из Shape 279
09.08.2019 14:09 Макрос для заполнения таблиц через форму 5167
18.07.2019 16:02 Рассылка почты из Excel при помощи почтовой программы TheBAT! 4555
07.02.2019 01:36 Как удалить дубликаты из выпадающего связанного списка? 6135
03.03.2018 00:00 Подсчет отработанного времени, за исключением заранее определенных перерывов 3234
23.05.2017 11:20 Копирование данных из одной таблицы в умную таблицу по условию 5050
15.03.2017 15:45 автозамена картинок PowerPoint 3961
11.03.2017 13:43 Изменить нумерацию страниц 3901
07.02.2017 18:43 Блокировка ячеек по наступлению даты 3019
28.08.2016 19:29 Одинаковые заголовки после обновления оглавления 3512





Яндекс цитирования msexcel.ru Яндекс.Метрика

Страница сгенерирована за 0.095 секунд. Запросов: 99.