Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Редакция ЖО

Автор iron priest, 08.12.2009, 10:10

« назад - далее »

iron priest

Хочу всетаки прилепить в обработку Алексея ЖО единицу измерения. решил уменьшить объем до выгрузки только ТМЦ. Изначально поэкспериментировал и сделал выгрузку справочника ТМЦ с указание единицы измерения:

Процедура Сформировать()
Таб=создатьобъект("Таблица");
Ит=создатьобъект("Справочник.ТМЦ");
ит.выбратьэлементы();
таб.вывестисекцию("секц");
Пока Ит.Получитьэлемент()=1 цикл
товар=ит.ПолнНаименование;
ед=ит.БазоваяЕдиница;
таб.вывестисекцию("секц");
//пока Ит.получитьэлемент()>0 цикл
// товар=ит.ПолнНаименование;
// ед=ит.БазоваяЕдиница;
КонецЦикла;


Таб.Показать();
КонецПроцедуры


и решил раз так все просто, то добавлю в код необходимые строки, вот что получилось
Процедура Сформировать()
Таб=СоздатьОбъект("Таблица");
Ит=СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.ТМЦ,,,);
Ит.ВключатьСубсчета(-1);
Ит.ВыполнитьЗапрос(НачДата, КонДата, ,,, 1,, 5);
ай=создатьобъект("Справочник.ТМЦ");
ай.выбратьэлементы();
Таб.ВывестиСекцию("Секция");
Ит.ВыбратьСчета();
пока ай.получитьэлемент()=1 цикл
ед=ай.БазоваяЕдиница;
    КонецЦикла;
Пока Ит.ПолучитьСчет()=1 Цикл;
Сбк=Ит.Счет.КоличествоСубконто();
Если Сбк = 0 Тогда;
ПолнНаименование=Ит.Счет.Наименование;   
дебск=ит.скд();
кредск=ит.скк();
дебсккол=ит.скд("К");
кредсккол=ит.скк("К");
дебсн=ит.снд();
кредсн=ит.снк();
дебснкол=ит.снд("К");
кредснкол=ит.снк("К");
Таб.ВывестиСекцию("Секция");

Иначе
Ит.ВыбратьСубконто(1,,,,,,1);
Пока Ит.ПолучитьСубконто() = 1 Цикл
ПолнНаименование=Ит.субконто(1);
дебск=ит.скд();
кредск=ит.скк();
дебсккол=ит.скд("К");
кредсккол=ит.скк("К");
дебсн=ит.снд();
кредсн=ит.снк();
дебснкол=ит.снд("К");
кредснкол=ит.снк("К");
Таб.ВывестиСекцию("Секция");
КонецЦикла;
КонецЕсли;
КонецЦикла;
Таб.Показать();
КонецПроцедуры


но 1с мне выгружает все ТМЦ с единицей измерения "шт.". залез на форум программистов 1с, но они по данной теме ничего конкретного не предлагают. Может кто-то подскажет что к чему.

ЗЫ: на форуме сказали обратиться еще к справочнику "Единицы"  :-\




iron priest

сделал немного другую выгрузку по всем ТМЦ. может кому пригодится

Шпец Докапыч

Попробовал обработочку:
ИТ.ИспользоватьСубконто("ТМЦ");
{C:\ВЫГРУЗКА ТМЦ.ERT(7)}: Число фильтров субконто превысило допустимое значение!


Может что-то можно подкрутить?
Конфигурация: Штрих-М: Торговое предприятие PROF 4x.
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

iron priest

#3
бог его знает, нада на работе подывыться

ЗЫ: первый раз такую конфу слышу :(


а как у вас в конфигураторе субконто товары называются? у меня ТМЦ, у вас может както иначе?