Подсчет суммы, минуя незаполненные ячейки.

Автор Игорь Кожин, 08.06.2013, 14:56

« назад - далее »

Игорь Кожин

В таблице есть пустые поля к которым не применена формула, мне нужно, минуя ячейки с ошибкой, посчитать сумму ячеек без ошибок, заранее применив к ним фильтрацию или как-то скрыть их. Таблица прилагается. Заранее спасибо.

kuklp

В С2:
=ЕСЛИ(ЕНД(ВПР(A2;Лист2!A:C;3;ЛОЖЬ));0;ВПР(A2;Лист2!A:C;3;ЛОЖЬ))
P.S. противно, эдак скоро формулистом стану ;D
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

Игорь Кожин

Спасибо большое.
ЦитироватьP.S. противно, эдак скоро формулистом стану
Главное, чтоб тебе и людям на пользу шло :)

edmar07

Цитата: KuklP от 08.06.2013, 15:48
=ЕСЛИ(ЕНД(ВПР(A2;Лист2!A:C;3;ЛОЖЬ));0;ВПР(A2;Лист2!A:C;3;ЛОЖЬ))
Можно сократить ;)
=ЕСЛИ(A8="";0;ВПР(A8;Лист2!A:C;3))

ну как-то так ...


alein

Ещё короче:
=IFERROR(VLOOKUP(A12,Лист2!A:C,3,FALSE),0)

Serge 007

IFERROR появилась в Excel 2007, следовательно работать в предыдущих версиях не будет

Начиная с Excel 2010 можно так (в С31):
=АГРЕГАТ(9;6;C2:C30)
Предварительно значения ошибки #Н/Д убирать не требуется
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Sarytai

Еще подойдет при положительных числах:
=СУММЕСЛИ(C2:C30;">0";C2:C30)

по крайней мере обходит ошибки и текст. Если же используются и отрицательные числа, то
=СУММЕСЛИ(C2:C30;">0";C2:C30)+СУММЕСЛИ(C2:C30;"<0";C2:C30)

Неизящно, но просто :)