Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Циклический вывод максимумов функции

Автор Андрій Лазоренко, 06.08.2013, 10:56

« назад - далее »

Андрій Лазоренко

Добрый день господа!
столкнулся с проблемой, мне нужно чтобы из зависимости выводилось максимум функции и промежуток этого максимума.....
у меня выходит вивести только одно значение...а мне нужно получить каждый максимум на промежутках....
подскажите как это можно сделать!

Спасибо

cheshiki1

максимумы
=ИНДЕКС($B$3:$B$47;НАИМЕНЬШИЙ(ЕСЛИ(($B$2:$B$46<$B$3:$B$47)*($B$3:$B$47>$B$4:$B$48);СТРОКА($B$3:$B$47)-2;"");СТРОКА(A1)))
формула массива вводится ctrl+shift+enter

Андрій Лазоренко

Цитата: cheshiki1 от 06.08.2013, 12:15
максимумы
=ИНДЕКС($B$3:$B$47;НАИМЕНЬШИЙ(ЕСЛИ(($B$2:$B$46<$B$3:$B$47)*($B$3:$B$47>$B$4:$B$48);СТРОКА($B$3:$B$47)-2;"");СТРОКА(A1)))
формула массива вводится ctrl+shift+enter


к сожелению, не считает у меня....

cheshiki1

смотрите

Андрій Лазоренко

Цитата: cheshiki1 от 06.08.2013, 14:24
смотрите

Спасибо!
НО!
на этой функции два максимума((
можно ли чтобы максиму считывался на промежутку, например 0;0 ?
тобиш если взят цифры из файла, то нужно получить:

А1-3
L1-2,3

A2-4,5
L2-(4,5-2,3) - 2,2

вот в этом проблема, что оно у меня не считае циклично(

есче раз - Спасибо)