Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Выборка в таблице по выпадающим спискам

Автор bar5uk, 21.06.2011, 12:37

« назад - далее »

bar5uk

Сожалею что приходится вновь писать просто прошлая тема случайно удалилась.
Суть вопроса. У меня есть несколько таблиц в которых надо найти значения по критериям выбранным в 2х выпадающих списках. В принципе в списках выбираются столбцы и строки самой таблицы. Пробовал делать через ИНДЕКС и ПОИСКПОЗ(примере видно), но ничего не получилось. Скажите что сделано не так или как поправить таблицу чтобы искалось значения(если можно через функции т.к. на макросы ругается антивирус и удаляет файл, да и понять бы хотелось как все это сделать так как таблица в файле всего лишь пример).
П.С. Списки править нельзя.

_Boroda_

=ИНДЕКС(I10:N15;ПОИСКПОЗ(C4;H10:H15;0);ПОИСКПОЗ(B4;I9:N9;0))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

bar5uk

ОГРОМНЕЙШЕЕ спасибо, очень выручили!!!