Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Учитывать заглавные буквы при использовании ВПР

Автор JiStokton, 06.04.2023, 09:25

« назад - далее »

JiStokton

Всем хорошего дня!

Столкнулась с такой проблемой - формула ВПР не учитывает того, с какой буквы начинается слово
Есть список, условно
Вера
вера
надежда
Надежда
Любовь
любовь

ВПР находит первое слово несмотря на то что нужно другое - ищу имя Надежда, получаю надежду :(

Помогите!

Serge 007

Здравствуйте

Вариант:=СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(A2;C2:C7))*D2:D7)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

JiStokton

Serge 007 спасибо но у меня ошибка ЗНАЧ показывает :(

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

JiStokton

У меня в столбце не цифры а наименования
Если ставлю их в файл - ошибка >:(

Serge 007

В следующий раз сами файл прикладывайте, что бы не гадать #чтогдеикак там у Вас

=ИНДЕКС(D2:D7;СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(A2;C2:C7))*СТРОКА(1:6)))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

JiStokton


JiStokton


Serge 007

Цитата: JiStokton от 06.04.2023, 16:24как это работает?

1. НАЙТИ(A2;C2:C7) - ищем искомое значение в просматриваемых с учетом регистра. Если найдено, то будет число (номер позиции вхождения), если не найдено - значение ошибки #ЗНАЧ!. В примере получается массив {#ЗНАЧ!:#ЗНАЧ!:#ЗНАЧ!:1:#ЗНАЧ!:#ЗНАЧ!}

2. ЕЧИСЛО({#ЗНАЧ!:#ЗНАЧ!:#ЗНАЧ!:1:#ЗНАЧ!:#ЗНАЧ!}) - значения ошибки нам не нужны. поэтому с помощью функции ЕЧИСЛО() отбираем только найденные значения, получаем {ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ}

3. {ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ}*СТРОКА(1:6) - присваиваем каждому значению в массиве свой индекс от одного до шести (СТРОКА(1:6) создает массив {1:2:3:4:5:6}) и перемножаем их: {ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ}*{1:2:3:4:5:6}. Получаем новый массив - {0:0:0:4:0:0}

4. СУММПРОИЗВ({0:0:0:4:0:0}) - суммируем все значения массива, получаем 4

5. ИНДЕКС(D2:D7;4) - возвращаем из диапазона D2:D7 значение, находящееся в 4-й строке
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

JiStokton


JiStokton

Правильно я понимаю что ВПР не получится использовать?

Serge 007

Да, напрямую - не получится
Функция ВПР - регистронезависимая (т.е. не различает строчные и прописные буквы)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

JiStokton