Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Присвоить буквам алфавита цифры

Автор Скобарь87, 11.04.2024, 09:54

« назад - далее »

Скобарь87

Добрый день. Подскажите, пожалуйста. Стоит задача присвоить буквам алфавита цифры. Причём с определённой тонкостью. Например: Алексеев Алексей  Алексеевич, а должно производиться 010101. Владимиров Дмитрий Борисович 030502. Вообщем, буква а-это 01, буква б-это 02, буква в- это 03. Хоть какую-нибудь идею подкиньте, пожалуйста. Хотя бы немного облегчить  работу. Спасибо

buchlotnik

=ТЕКСТ(КОДСИМВ(ЛЕВБ(A1))-191;"00")&ТЕКСТ(КОДСИМВ(ЛЕВБ(B1))-191;"00")&ТЕКСТ(КОДСИМВ(ЛЕВБ(C1))-191;"00")

или

=СЦЕП(ТЕКСТ(КОДСИМВ(ЛЕВБ(ТЕКСТРАЗД(F1;" ")))-191;"00"))