Сложение ячеек при определенном условии

Автор siriusdesign, 18.05.2014, 00:33

« назад - далее »

siriusdesign

Добрый день.

я знаю как складываются ячейки
=ячейка1 & "," & ячейка2 & "," & ячейка3 & "," & ячейка4

здесь сложение происходит в случае наличия значение в ячейке 2
=ЕСЛИ(ячейка2<>"";ячейка1 & "," & ячейка2 & "," & ячейка3;""

А как сделать чтобы если нет значения в ячейке – она не принимала участие в сложении

кроссеров ни на одном форуме не любят, следующий раз можете не дождаться ответа.

Serge 007

Так надо?
=A1&ЕСЛИ(ЕПУСТО(A1);"";",")&B1&ЕСЛИ(ЕПУСТО(B1);"";",")&C1&ЕСЛИ(ЕПУСТО(C1);"";", ")&D1&ЕСЛИ(ЕПУСТО(D1);"";",")

http://www.excelworld.ru/forum/2-10811-1#94170
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

siriusdesign не тех двух форумах в которых вы написали 80% помогающих одни и те же люди. ) так что не вижу смысла косить, а вот на нулевой ответ нарваться можно. :)

siriusdesign

ок учту это

да все правильно, только как еще сделать, чтобы в случае если отсутствуют значения в к примеру в двух последних ячейках, запятая не ставилась в конце для ячейки в которой было значение