Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Первая занятая строка

Автор 0mega, 19.05.2014, 14:15

« назад - далее »

0mega

Всем доброго времени суток.
2003
sub no

есть текстовый столбец
Запись в столбце сделана не с первой строки и внутри столбца есть пропуски
Надо найти первую запись

Напр.

.
.
.

клей
13
.
.

текст
АН17

машина должна найти "Клей"

* белые точки - это "пустые строки"

cheshiki1

формула массива=ИНДЕКС(B3:B20;МИН(ЕСЛИ(ЕПУСТО(B3:B20);"";СТРОКА(B1:B18))))

Serge 007

Чуть попроще, но для текста:=ВПР("*";B3:B20;1;)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

0mega

Serge 007, спасибо.
интересная формула. Очень жаль что заточена только под текст ...

cheshiki1, нечто аналогичное я пытался "родить" самостоятельно. Объясните один момент. Ведь, начальные пустые ячейки легче чем любая занятая.
В своей формуле Вы используете ...МИН(ЕСЛИ(...
Логика подсказывает что, при минимуме, формула должна выбирать не первую занятую, а первую пустую ячейку  ?!

cheshiki1

для этого и используется ЕСЛИ, она заменяет пустую на как бы пустую текстовую (текст всегда больше числа), а не пустую на номер строки (число) согласно указанного диапазона. т.е у нас получается массив {текст;2;текст;текст;5;6....}

0mega

благодарю за детальное объяснение