Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Формула Количество минут

Автор Maria_R, 23.05.2014, 13:31

« назад - далее »

Maria_R

Всем добрый день! Помогите, пожалуйста, в отдельный столбец проставить количество минут (нужна формула) - ячейка С2, если имеется информация о длительности вызова в формате 00:00:00 (пример в приложении).
Заранее спасибо!

cheshiki1

формат ячейки - [мм] не подходит?
или тоже самое формулой =ТЕКСТ(B2;"[мм]")

Maria_R

Добрый день, спасибо Вам большое за помощь! Дело в том, что нам нужно пересчитать услуги за связь. А данная формула, к сожалению, не округляет в бОльшую сторону минуты (т.е. 01:05:05 провайдеры считают как 2 минуты). Кроме того, минуты в этой формуле получаются в текстовом формате, а нужно в числовом. Буду признательна, если сможете помочь. Спасибо.

cheshiki1

#3
=ОКРУГЛВВЕРХ(ЧАС(B2)*60+МИНУТЫ(B2)+СЕКУНДЫ(B2)/60;0)
или
=ОКРУГЛВВЕРХ(ТЕКСТ(B2;"[с]")/60;0)

Цитировать01:05:05 провайдеры считают как 2 минуты
у вас значения с миллисекундами?

VictorK

#4
=ОКРУГЛВВЕРХ(B2*1440;0)

gling

Вот такой обман клиентов связи происходит. Все в файле. За одну сек. разговора платим за минуту))). Возможно формулу можно упростить, но мне лень.
mail: vovik100661@gmail.com;
ЯД-41001506838083.

VictorK

Цитата: gling от 23.05.2014, 23:40
Вот такой обман клиентов связи происходит. За одну сек. разговора платим за минуту
gling, на самом деле никакого обмана нет, в договоре клиента с оператором как правило указывается - "Тарификация исходящих соединений поминутная с 6-ой секунды" или что то похожее. Подписывая договор, Вы соглашаетесь с его условиями.
Возвращаясь к вопросу Maria_R, - округление до минут нужно именно в числовом формате, а не в формате "время", для вычисления стоимости разговора, чтобы можно было умножить тариф за минуту разговора на продолжительность разговора в минутах (если умножать на значения в формате "время", получим неверный результат).

gling

Да, действительно, про числовой формат я что то упустил. Тогда такая формула=ЧАС(B2)*60+МИНУТЫ(B2)+ЕСЛИ(СЕКУНДЫ($B2)>0;1;0)
mail: vovik100661@gmail.com;
ЯД-41001506838083.

zs

#8
=ЕСЛИ(СЕКУНДЫ(B3)>0;ВРЕМЯ(ЧАС(B3);(МИНУТЫ(B3)+1);СЕКУНДЫ(0))*24*60;ВРЕМЯ(ЧАС(B3);МИНУТЫ(B3);СЕКУНДЫ(0))*24*60)

Maria_R

Цитата: VictorK от 24.05.2014, 13:37
Цитата: gling от 23.05.2014, 23:40
Вот такой обман клиентов связи происходит. За одну сек. разговора платим за минуту
gling, на самом деле никакого обмана нет, в договоре клиента с оператором как правило указывается - "Тарификация исходящих соединений поминутная с 6-ой секунды" или что то похожее. Подписывая договор, Вы соглашаетесь с его условиями.
Возвращаясь к вопросу Maria_R, - округление до минут нужно именно в числовом формате, а не в формате "время", для вычисления стоимости разговора, чтобы можно было умножить тариф за минуту разговора на продолжительность разговора в минутах (если умножать на значения в формате "время", получим неверный результат).
Вы абсолютно правы, спасибо за поддержку!

Maria_R

Цитата: gling от 24.05.2014, 20:03
Да, действительно, про числовой формат я что то упустил. Тогда такая формула=ЧАС(B2)*60+МИНУТЫ(B2)+ЕСЛИ(СЕКУНДЫ($B2)>0;1;0)
Добрый день! Спасибо Вам большое за формулу!

Maria_R

Цитата: zs от 25.05.2014, 15:41
=ЕСЛИ(СЕКУНДЫ(B3)>0;ВРЕМЯ(ЧАС(B3);(МИНУТЫ(B3)+1);СЕКУНДЫ(0))*24*60;ВРЕМЯ(ЧАС(B3);МИНУТЫ(B3);СЕКУНДЫ(0))*24*60)
Добрый день! Вам также большое спасибо!

Maria_R

Я всем очень признательна за Вашу помощь и участие! Отличного Вам времени суток!

ВЕВ

Добрый день! Не буду создавать новую тему, а спрошу помощи здесь. Я пользуюсь формулой, которая находит продолжительность в минутах, после того, как я введу время в формате чч,мм (важно, что разделитель - запятая). Но мне необходимо, чтобы из этого промежутка исключалась продолжительность определенных интервалов, если они выпадают на это время.
Например, ввожу 8,00 и 10,00. По формуле 120 мин. Но есть интервал с 9,30 до 9,40 (список интервалов постоянный и не изменяется, только они бывают разной продолжительности). И необходимо, чтобы программа определила, что этот интервал выпадает на то время, которое я ввожу, и отняла его. Чтобы в итоге получилось 110 мин. Прикрепляю файл. Заранее, Спасибо!

vikttur

Задача другая. Создайте тему с названием, отражающим суть задачи