Замена цифровых значений

Автор maksym.bh, 23.06.2014, 11:48

« назад - далее »

maksym.bh

Добрый день.
Возник вот такой вопрос.
Есть список телефонов. Список хаотичный. Некоторые телефоны начинаются с +7, некоторые с 8, некоторые просто с 7. Подскажите какой формулой можно их все привести в единый вид. Чтобы все телефоны начинались с 7.
Просто замена не подходит, т.к. если например заменить 89 на 79 поменяются все значения в строке.

Serge 007

Так как файла нет, то так:
=ЕСЛИ(ЛЕВБ(A1)="8";7&ПСТР(A1;2;10);ПОДСТАВИТЬ(A1;"+";))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

vikttur